New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Mounting Failed error on Ubuntu 14.04 #256

Closed
hckweb opened this Issue Apr 30, 2016 · 12 comments

Comments

Projects
None yet
4 participants
@hckweb
Copy link

hckweb commented Apr 30, 2016

  • I'm running Cryptomator on: Ubuntu 14.04 (using .deb installer)
  • I'm using Cryptomator in version: 1.0.3

I have a problem about mounting.

crypto

Here is log file:

2016-04-30 22:03:29,791 INFO  [SingleInstanceManager:299] no running instance found
2016-04-30 22:03:31,209 DEBUG [SingleInstanceManager:325] InstanceManager bound to port 40157
2016-04-30 22:03:35,705 DEBUG [CommandResult:85] Command execution finished. Exit code: 0
Output: /usr/bin/gvfs-mount
/usr/bin/xdg-open

2016-04-30 22:03:35,706 INFO  [WebDavMounterProvider:39] Using LinuxGvfsWebDavMounter
2016-04-30 22:03:35,722 INFO  [log:186] Logging initialized @6589ms
2016-04-30 22:03:35,814 INFO  [Server:345] jetty-9.3.3.v20150827
2016-04-30 22:03:35,856 INFO  [ContextHandler:775] Started o.e.j.s.ServletContextHandler@42c4690e{/,null,AVAILABLE}
2016-04-30 22:03:35,871 INFO  [ServerConnector:270] Started ServerConnector@5c17d5f5{HTTP/1.1,[http/1.1]}{0.0.0.0:33169}
2016-04-30 22:03:35,872 INFO  [Server:397] Started @6741ms
2016-04-30 22:03:35,872 INFO  [WebDavServer:79] Cryptomator is running on port 33169
2016-04-30 22:03:36,613 INFO  [WebDavServer:117] Servlet available under http://localhost:33169/crypto
2016-04-30 22:03:36,618 INFO  [AbstractWebdavServlet:169] authenticate-header = Basic realm="Jackrabbit Webdav Server"
2016-04-30 22:03:36,620 INFO  [AbstractWebdavServlet:174] csrf-protection = null
2016-04-30 22:03:36,620 INFO  [AbstractWebdavServlet:181] createAbsoluteURI = true
2016-04-30 22:03:36,620 INFO  [ContextHandler:775] Started o.e.j.s.ServletContextHandler@495bc732{/crypto,null,AVAILABLE}
2016-04-30 22:03:36,631 DEBUG [CommandResult:83] Command execution finished. Exit code: 0
2016-04-30 22:03:36,738 DEBUG [CommandResult:87] Command execution finished. Exit code: 2
Error: Konum bağlanırken hata: HTTP Hatası: Connection terminated unexpectedly

2016-04-30 22:03:36,739 ERROR [UnlockController:301] Decryption failed for technical reasons.
org.cryptomator.frontend.FrontendCreationFailedException: org.cryptomator.frontend.CommandFailedException: Command execution failed. Exit code: 2 
# Output:

# Error: 
Konum bağlanırken hata: HTTP Hatası: Connection terminated unexpectedly

    at org.cryptomator.ui.model.Vault.activateFrontend(Vault.java:137) ~[Cryptomator-1.0.3.jar:1.0.3]
    at org.cryptomator.ui.controllers.UnlockController.unlock(UnlockController.java:280) ~[Cryptomator-1.0.3.jar:1.0.3]
    at org.cryptomator.ui.controllers.UnlockController.lambda$didClickUnlockButton$0(UnlockController.java:274) ~[Cryptomator-1.0.3.jar:1.0.3]
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_74]
    at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_74]
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [?:1.8.0_74]
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [?:1.8.0_74]
    at java.lang.Thread.run(Thread.java:745) [?:1.8.0_74]
Caused by: org.cryptomator.frontend.CommandFailedException: Command execution failed. Exit code: 2 
# Output:

# Error: 
Konum bağlanırken hata: HTTP Hatası: Connection terminated unexpectedly

    at org.cryptomator.frontend.webdav.mount.command.CommandResult.assertOk(CommandResult.java:98) ~[frontend-webdav-1.0.3.jar:?]
    at org.cryptomator.frontend.webdav.mount.command.CommandRunner.execute(CommandRunner.java:69) ~[frontend-webdav-1.0.3.jar:?]
    at org.cryptomator.frontend.webdav.mount.command.Script.execute(Script.java:38) ~[frontend-webdav-1.0.3.jar:?]
    at org.cryptomator.frontend.webdav.mount.LinuxGvfsWebDavMounter.mount(LinuxGvfsWebDavMounter.java:55) ~[frontend-webdav-1.0.3.jar:1.0.3]
    at org.cryptomator.frontend.webdav.WebDavFrontend.mount(WebDavFrontend.java:48) ~[frontend-webdav-1.0.3.jar:1.0.3]
    at org.cryptomator.ui.model.Vault.activateFrontend(Vault.java:134) ~[Cryptomator-1.0.3.jar:1.0.3]
    ... 7 more
@overheadhunter

This comment has been minimized.

Copy link
Member

overheadhunter commented May 1, 2016

Is there any firewall etc that might interfere with loopback http connections?

@hckweb

This comment has been minimized.

Copy link

hckweb commented May 2, 2016

I used to use a firewall. I disable and remove it but the problem is not solved.

@hckweb

This comment has been minimized.

Copy link

hckweb commented May 11, 2016

I thought this problem might be because of my old and dirty system.
So I installed lubuntu 16.04 to an another pc. But problem is the same with this clean system.

I'm running Cryptomator on: Lubuntu 16.04 (using .deb installer)
I'm using Cryptomator in version: 1.0.5
2016-05-11 20:33:24,589 INFO  [Cryptomator:40] Starting Cryptomator 1.0.5 on Linux 4.4.0-22-generic (amd64)
2016-05-11 20:33:24,629 INFO  [SingleInstanceManager:299] no running instance found
2016-05-11 20:33:25,626 INFO  [MainApplication:41] JavaFX application started
2016-05-11 20:33:25,715 INFO  [Localization:42] Loaded localization from /localization/tr.txt
2016-05-11 20:33:26,090 INFO  [SettingsProvider:88] Failed to load settings, creating new one.
2016-05-11 20:33:29,892 DEBUG [SingleInstanceManager:325] InstanceManager bound to port 41491
2016-05-11 20:33:31,512 DEBUG [WelcomeController:151] Current version: 1.0.5, lastest version: 1.0.4
2016-05-11 20:33:45,633 INFO  [SettingsProvider:113] Settings saved to /home/cem/.Cryptomator/settings.json
2016-05-11 20:33:54,264 DEBUG [CommandResult:85] Command execution finished. Exit code: 0
Output: /usr/bin/gvfs-mount
/usr/bin/xdg-open

2016-05-11 20:33:54,274 INFO  [WebDavMounterProvider:39] Using LinuxGvfsWebDavMounter
2016-05-11 20:33:54,384 INFO  [log:186] Logging initialized @32104ms
2016-05-11 20:33:55,344 INFO  [Server:345] jetty-9.3.3.v20150827
2016-05-11 20:33:55,685 INFO  [ContextHandler:775] Started o.e.j.s.ServletContextHandler@60c3c892{/,null,AVAILABLE}
2016-05-11 20:33:55,752 INFO  [ServerConnector:270] Started ServerConnector@30241b8c{HTTP/1.1,[http/1.1]}{0.0.0.0:42427}
2016-05-11 20:33:55,761 INFO  [Server:397] Started @33496ms
2016-05-11 20:33:55,762 INFO  [WebDavServer:79] Cryptomator is running on port 42427
2016-05-11 20:33:57,263 INFO  [WebDavServer:117] Servlet available under http://localhost:42427/deneme
2016-05-11 20:33:57,308 INFO  [AbstractWebdavServlet:169] authenticate-header = Basic realm="Jackrabbit Webdav Server"
2016-05-11 20:33:57,323 INFO  [AbstractWebdavServlet:174] csrf-protection = null
2016-05-11 20:33:57,334 INFO  [AbstractWebdavServlet:181] createAbsoluteURI = true
2016-05-11 20:33:57,335 INFO  [ContextHandler:775] Started o.e.j.s.ServletContextHandler@629314e9{/deneme,null,AVAILABLE}
2016-05-11 20:33:57,428 DEBUG [CommandResult:83] Command execution finished. Exit code: 0
2016-05-11 20:33:58,357 DEBUG [CommandResult:87] Command execution finished. Exit code: 2
Error: Konum bağlanırken hata: HTTP Hatası: Connection terminated unexpectedly

2016-05-11 20:33:58,360 ERROR [UnlockController:301] Decryption failed for technical reasons.
org.cryptomator.frontend.FrontendCreationFailedException: org.cryptomator.frontend.CommandFailedException: Command execution failed. Exit code: 2 
# Output:

# Error: 
Konum bağlanırken hata: HTTP Hatası: Connection terminated unexpectedly

    at org.cryptomator.ui.model.Vault.activateFrontend(Vault.java:139) ~[Cryptomator-1.0.5.jar:1.0.5]
    at org.cryptomator.ui.controllers.UnlockController.unlock(UnlockController.java:280) ~[Cryptomator-1.0.5.jar:1.0.5]
    at org.cryptomator.ui.controllers.UnlockController.lambda$didClickUnlockButton$11(UnlockController.java:274) ~[Cryptomator-1.0.5.jar:1.0.5]
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_92]
    at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_92]
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [?:1.8.0_92]
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [?:1.8.0_92]
    at java.lang.Thread.run(Thread.java:745) [?:1.8.0_92]
Caused by: org.cryptomator.frontend.CommandFailedException: Command execution failed. Exit code: 2 
# Output:

# Error: 
Konum bağlanırken hata: HTTP Hatası: Connection terminated unexpectedly

    at org.cryptomator.frontend.webdav.mount.command.CommandResult.assertOk(CommandResult.java:98) ~[frontend-webdav-1.0.5.jar:?]
    at org.cryptomator.frontend.webdav.mount.command.CommandRunner.execute(CommandRunner.java:69) ~[frontend-webdav-1.0.5.jar:?]
    at org.cryptomator.frontend.webdav.mount.command.Script.execute(Script.java:38) ~[frontend-webdav-1.0.5.jar:?]
    at org.cryptomator.frontend.webdav.mount.LinuxGvfsWebDavMounter.mount(LinuxGvfsWebDavMounter.java:55) ~[frontend-webdav-1.0.5.jar:?]
    at org.cryptomator.frontend.webdav.WebDavFrontend.mount(WebDavFrontend.java:48) ~[frontend-webdav-1.0.5.jar:?]
    at org.cryptomator.ui.model.Vault.activateFrontend(Vault.java:136) ~[Cryptomator-1.0.5.jar:1.0.5]
    ... 7 more
@overheadhunter

This comment has been minimized.

Copy link
Member

overheadhunter commented May 12, 2016

Still the question is why the

Connection terminated unexpectedly

From the logfile we can see that there are no incoming connections.

Can you try mounting webdav://localhost:42427/deneme manually after pressing unlock?

@hckweb

This comment has been minimized.

Copy link

hckweb commented May 12, 2016

webdav://localhost:42427/deneme
returns "Belirtilen konum desteklenmiyor" means "The path is not supported"

dav://localhost:42427/deneme
returns "HTTP Hatası (means "Error"): Connection terminated unexpectedly" and "The path is not mounted"

Also I can connect my owncloud account with webdav (dav://...)

@overheadhunter

This comment has been minimized.

Copy link
Member

overheadhunter commented May 12, 2016

can you try telnet localhost 42427?

@hckweb

This comment has been minimized.

Copy link

hckweb commented May 12, 2016

user@lubuntu:$ telnet localhost 42427
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
Connection closed by foreign host.
user@lubuntu:
$

@overheadhunter

This comment has been minimized.

Copy link
Member

overheadhunter commented May 12, 2016

Something is blocking the connection.
@markuskreusch any idea? hckweb already tried disabling the firewall.

edit: wait, how many time has passed between those two lines?

Escape character is '^]'.
Connection closed by foreign host.

@hckweb

This comment has been minimized.

Copy link

hckweb commented May 12, 2016

user@lubuntu:~$ time telnet localhost 42427
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
Connection closed by foreign host.

real 0m0.011s
user 0m0.004s
sys 0m0.000s
user@lubuntu:~$

So quick.

@markuskreusch markuskreusch modified the milestone: Backlog Aug 9, 2016

@overheadhunter

This comment has been minimized.

Copy link
Member

overheadhunter commented Apr 6, 2018

Today we released our first beta of 1.4.0, which brings FUSE support to macOS and Linux.

Please retest this issue with FUSE enabled and report your findings in this thread.


If you experience any new issues, please report them and tell us what software version (including macOS version, linux kernel, display manager, desktop environment) you're using.

⚠️ This is a beta version! Make backups and don't use this version for production data. ⚠️

@stale

This comment has been minimized.

Copy link

stale bot commented Jun 17, 2018

This issue has been automatically marked as stale because it has not had recent activity. It will be closed if no further activity occurs. Thank you for your contributions.

@stale stale bot added the state:stale label Jun 17, 2018

@no-response no-response bot closed this Jun 17, 2018

@no-response

This comment has been minimized.

Copy link

no-response bot commented Jun 17, 2018

This issue has been automatically closed because there has been no response to our request for more information from the original author. With only the information that is currently in the issue, we don't have enough information to take action. Please reach out if you have or find the answers we need so that we can investigate further.

@overheadhunter overheadhunter added this to the 1.4.0 milestone Jun 17, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment