New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

1.4.0 beta bug #672

Closed
peterleerental opened this Issue May 5, 2018 · 2 comments

Comments

Projects
None yet
3 participants
@peterleerental
Copy link

peterleerental commented May 5, 2018

1.4.0 Beta Issue Checklist

Software Used During the Test

  • Cryptomator 1.4.0 Beta 1
  • Ubuntu 16.04
  • Linux Kernel 4.13.0-39-generic
  • Gnome 3.18.3
  • LibreOffice 6.0.3.2
  • ...

Description

I've tried the appimage beta on Ubuntu 16.04 but if I try to open a LibreOffice base document in the Fuse drive (/home/user/.Cryptomator/WorkaroundS0hTQka6RhCa/database.odb) I get a permissions error ("Access to (file) was denied").
It works fine with a .pdf file but not with LibreOffice documents: if I use “reveal drive” I can copy and paste a document into the drive but then can’t open it, either from Nautilus or even from the Cryptomator drive.

If I try to open the a .odb file from LibreOffice Base I get a 'could not read the contents of .Cryptomator' error - permission denied.

I don’t have any technical knowledge, so unless you can explain a solution very simply could you at least say whether I’m the only one with this problem, and if not is a fix on the horizon?

UPDATE: I replaced LibreOffice 6 with Version 5.1.6.2 and the files opened no problem.
FURTHER UPDATE: After much purging and autoremoving I've uninstalled and reinstalled LibreOffice 6 and it now works on Cryptomator. Apologies for wasting anyone's time.


@overheadhunter overheadhunter added this to the 1.4.0 milestone May 7, 2018

@gleanfield

This comment has been minimized.

Copy link

gleanfield commented May 10, 2018

Given OP's updates (latest May 9, 2018), can this issue be closed?

Fwiw I can successfully open Libreoffice (version Version: 5.2.7.2 Build ID: 1:5.2.7-1+deb9u4) Calc files in fuse mounts with the following setup:

  • Debian GNU/Linux 9 ("stretch"; 4.9.0-6-amd64 #1 SMP Debian 4.9.88-1+deb9u1 x86_64)
  • xfce4 (version 4.12.3)
  • Cryptomator (version 1.4.0 Beta 1) with mount method FUSE
  • fuse (version 2.9.7-1) from Debian stable repository
@peterleerental

This comment has been minimized.

Copy link
Author

peterleerental commented May 10, 2018

As the OP, as far as I'm concerned this problem can be considered closed.

@overheadhunter overheadhunter removed this from the 1.4.0 milestone May 11, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment