Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Support LLVM 5.0 postfixed versions #5531

Merged
merged 1 commit into from
Jan 4, 2018

Conversation

Vexatos
Copy link
Contributor

@Vexatos Vexatos commented Jan 4, 2018

Basically a clone of #5013 for LLVM 5.0. See there for reasons.
#5058 already tried that and LLVM 5.0 was not considered sufficiently stable at the time, but it's three months later and it has been promoted to the default version in many distributions, so I think it is fair to make it the default here as well.

@RX14
Copy link
Contributor

RX14 commented Jan 4, 2018

Perhaps we should think about templating those excessively long shell invocations though.

@RX14 RX14 added this to the Next milestone Jan 4, 2018
@RX14 RX14 merged commit 0ea5ca0 into crystal-lang:master Jan 4, 2018
@ysbaddaden
Copy link
Contributor

👍 I've been using Crystal with LLVM5 by default for some time now, and found no issues.

@waghanza
Copy link

@ysbaddaden nice to hear llvm 5 is supported.
I think we need to update https://crystal-lang.org/docs/installation/from_source_repository.html

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

5 participants