Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

change numpy1.7 useflag to numpy17. Dots in useflags are a bad idea.

Package-Manager: portage-2.2.0_alpha144
  • Loading branch information...
commit 48b3fea1debb730f4d52bc107d1eb6c470839a53 1 parent 9d173fe
@kiwifb kiwifb authored
View
4 sci-mathematics/sage/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 10 Dec 2012; François Bissey <francois.bissey@canterbury.ac.nz>
+ sage-5.4.1-r2.ebuild, sage-5.5_rc0.ebuild, metadata.xml:
+ change useflag to numpy17 no dots please
+
*sage-5.5_rc0 (06 Dec 2012)
06 Dec 2012; François Bissey <francois.bissey@canterbury.ac.nz>
View
8 sci-mathematics/sage/Manifest
@@ -12,7 +12,7 @@ AUX trac_11395_update_gfan_to_0.5.patch 4037 SHA256 703c53ac64f3e81190cca6c5aa2f
AUX trac_13740_final_fixes.patch 4550 SHA256 72072e190b6eb314f3a1c8451a972437bfdad00fdbbf7576d1fbaecacc2a391f SHA512 15aed3e65bf60b143c8822202eca0b7f734105f320bc869198e8a6c42b48a0adde108a7bd539929d4760c8958957d83d759a7c1643329bab3e5d8153a337bd0a WHIRLPOOL 0efad8c210b8d09fa2b444fb4034eb0071f657cb70a307e3d875ff4b002e6b44492053bdb112084a1bb8ba627cdc2ac902d7409576e91fb9cac5541b88eb19d3
DIST sage-5.4.1.tar.bz2 57938960 SHA256 8b89839123c04b5c6c22701197affc358cd0fcdce806a828d8b076104d836696 SHA512 20d88c238c8aa670d2e43e1e22ab223583d76537e59d11f5ee0f8cd41051a5195238ccbc34bdb766db74d1123ee1fc0e37e03b36e9ef1df46e77c6cb2149fa4a WHIRLPOOL 4d4eac9f910bef09d64e4e76a3963fa677c6bf973ed05c1b18ae82bd65a3503b7082d90fd26233f7e9e538e89f959176b8c9637dcedf992806fdc32848bc614a
DIST sage-5.5_rc0.tar.bz2 58408189 SHA256 37bb96ac7b40a3c4f3e86439d549c41138e0edc7594faea9cc01e1529798d83d SHA512 8b529780b85f2cb1c907fe32d83ff1fa463ad21badb97c273a8a8157d0294c7b6fc2ecfb97877d5835f7525aefaa8aa1be6db8da7ce15291138e02f7900c04d7 WHIRLPOOL e0a70b672f3072bd6cf55613dbd06e7a92db8163208bbceb06acb87f31f2daa407a5ee620c61ae8f18cae4a0ac10ec1428a6a380697fc0ba29f4ad7fb7e62d5b
-EBUILD sage-5.4.1-r2.ebuild 12630 SHA256 cde6cdc2d15a4eec6c5c8216cdf04884fc0767c4bf56c995b5df6e577001c517 SHA512 964b622191b8f1e01dad9eb666a1e10497c217fea7f8e530de9225ad5b56870274853cb57f29ade2d19ef0aa3656ccf64f288ad22ac2390982486cf02ef7f821 WHIRLPOOL ec3c8466aba1afe1c13bc8129b4f5a6f7dd795d9c49c7ed6fc7a8c49ae7ebeece6b2a22d97a6a0915b3add5dc141a5f0696bbdcd2b70483b0c2068a76d71cdae
-EBUILD sage-5.5_rc0.ebuild 12487 SHA256 fe55cf3addee558594488c951a27ee793d781fbcfd64ddb18242fd85cb800c91 SHA512 75e94a4747ba7e91294f8a129f3e2a6987a332a3d37d7225de8b210a1dbc0f63a169cbd185c3fcd877f6f3cf20fb4b73d4fbf1a698d3e208eb78c34c2e05b9b2 WHIRLPOOL 333f6cb11592ea8e71b3ed6466e59468751473ca08107fde4c39801260d76bfa73e2022547e7276b53f846d6e4474d62df4431eec36ed32d41c3b8ffcdbe3530
-MISC ChangeLog 88370 SHA256 01b21606da17434b9569da1f94c03971803489866a145fca9e9aa3e0416ec5b2 SHA512 d5078e5d27bf9c8477065ace781e4667e625fd85461dcf2664661a31bdcf6ea87bf188b4543d99c915f31a88eead17bed18dcb8d989472a92315953f4f462bc1 WHIRLPOOL e5bcb51524157e19e4b7876bcf64b90345660bcb4c14edfea48c0e08cb21f0c9eeced974c6dd649bbe6af3ba9188f3ec75c50b7304d2da9de74bbccf49a691f0
-MISC metadata.xml 449 SHA256 43aa0b81bc30d8a4091f8547483fe12d019883330c30aac703aa529578c89a3b SHA512 433127c1ea1444e5cdcebe631bff53da6ede028d6790b04508991bad504594760fd32a604c6edd193b427d7bb67f9afb8b7723fa62810ebf4a8536507b2958ea WHIRLPOOL 15ed1a57dcb15d7113b7e2bf7f61bac08ba632c77b533b11fbcb1c436264a06b73c99e413736da579b407c08a39d93476d2c01d6eb982f20394c36fdf88ebb76
+EBUILD sage-5.4.1-r2.ebuild 12626 SHA256 03ab65c3652bd352c102b0f9d5aa60ce1a49e10842c1fff7dd3a6385908354a7 SHA512 be5d15242f9f1dcce0dde402b01ecdee00673e735bd69e98a4180c027a43d374d87d4294b0f9f4a8e67ec6ec79beb4b5f6b2c38852970b367c287391ab487ef3 WHIRLPOOL 8648382f35563a5cd488a1d669167be322c792f6d3f533b56cfa4dd101d2874403a83712ac113b9cb9f0c0e0ac4698c5abaab4b1e71fc2c82b1feff21dadf2bc
+EBUILD sage-5.5_rc0.ebuild 12483 SHA256 ba7f05a5dde5fa0c72426c061160dcdb068e2f2999303fa43fee399d836ee4a8 SHA512 f44bb086de92490969641774b907e2de9ca8b7845cd19c1fe18f4639154389a14b0c6470e2b81e3c29f63da7b63372b596e0b8c1f92a8ae13509b2a4c36b1807 WHIRLPOOL 95d92d590def6d101f5924948e2d72634dd8c3ef0f38cc6a470949b85c904bf5e3ad4ae8df00a7b2969e505af4919ed81e7b30884bc220b07fd7f9ba598129db
+MISC ChangeLog 88540 SHA256 e5b433e5ce62c93f558ee92d6b8dd279d733875a5ccaaec146de417662f5e444 SHA512 f26467715823fa9240c0030f3bec8a71d7b453b6ce288b354ce8df4359ac48c68e35b394acbe0c55c0c5aa51db4732e284211288634054af8ea59ac608b3d9dc WHIRLPOOL a50abc105ee125081abe6127246186c742db477f8db3beaa65a9fd74a2d06d4699dd386750b4111b8366e3a1fa2daafcfefbb96a5febaa9e432985daada8781f
+MISC metadata.xml 448 SHA256 8dded7f2857796c09ff032b096000d9aa7f076c71f150b85f08c3732a9c5fdcc SHA512 fcb301781c3e76f862b168e1bef40de191a196b771142edf6e1f2ed2e6b73ee9b45fcb205fd2ece586eee00e67e4b7d219ba1bd7ac025f9f5dc2db454050ea1b WHIRLPOOL ef74b18c989a7fbc85efaaca24459a3d65a7ba26349df35ebe1f97e75c7cdbd5b013063453d53da283e3cf85c9d391a2097dbb9896ab7165ee360e199a8e2a63
View
2  sci-mathematics/sage/metadata.xml
@@ -10,7 +10,7 @@
If activated installs Sage's sources into
/usr/share/sage/devel/sage to enable testing
</flag>
- <flag name='numpy1.7'>
+ <flag name='numpy17'>
Use the beta of numpy 1.7 and associated patches
</flag>
</use>
View
8 sci-mathematics/sage/sage-5.4.1-r2.ebuild
@@ -21,7 +21,7 @@ SRC_URI="http://sage.math.washington.edu/home/release/${MY_P}/${MY_P}/spkg/stand
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-macos"
-IUSE="latex numpy1.7 testsuite"
+IUSE="latex numpy17 testsuite"
RESTRICT="mirror test"
@@ -31,8 +31,8 @@ CDEPEND="dev-libs/gmp
>=dev-libs/ntl-5.5.2
>=dev-libs/ppl-0.11.2
>=dev-lisp/ecls-11.1.1-r1
- numpy1.7? ( >=dev-python/numpy-1.7.0_beta2 )
- !numpy1.7? ( ~dev-python/numpy-1.5.1 )
+ numpy17? ( >=dev-python/numpy-1.7.0_beta2 )
+ !numpy17? ( ~dev-python/numpy-1.5.1 )
~dev-python/cython-0.17.2
~sci-mathematics/eclib-20120428
>=sci-mathematics/ecm-6.3
@@ -124,7 +124,7 @@ pkg_setup() {
python_set_active_version 2.7
python_pkg_setup
# warn if numpy 1.7 is used
- if use numpy1.7; then
+ if use numpy17; then
ewarn "you have enabled the use of numpy1.7, this is unsupported upstream"
ewarn "it will generate lots of noise and an oddity here and there."
ewarn "see http://trac.sagemath.org/sage_trac/ticket/11334 for details"
View
8 sci-mathematics/sage/sage-5.5_rc0.ebuild
@@ -21,7 +21,7 @@ SRC_URI="http://sage.math.washington.edu/home/release/${MY_P}/${MY_P}/spkg/stand
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-macos"
-IUSE="latex numpy1.7 testsuite"
+IUSE="latex numpy17 testsuite"
RESTRICT="mirror test"
@@ -31,8 +31,8 @@ CDEPEND="dev-libs/gmp
>=dev-libs/ntl-5.5.2
>=dev-libs/ppl-0.11.2
>=dev-lisp/ecls-11.1.1-r1
- numpy1.7? ( >=dev-python/numpy-1.7.0_beta2 )
- !numpy1.7? ( ~dev-python/numpy-1.5.1 )
+ numpy17? ( >=dev-python/numpy-1.7.0_beta2 )
+ !numpy17? ( ~dev-python/numpy-1.5.1 )
~dev-python/cython-0.17.2
~sci-mathematics/eclib-20120428
>=sci-mathematics/ecm-6.3
@@ -124,7 +124,7 @@ pkg_setup() {
python_set_active_version 2.7
python_pkg_setup
# warn if numpy 1.7 is used
- if use numpy1.7; then
+ if use numpy17; then
ewarn "you have enabled the use of numpy1.7, this is unsupported upstream"
ewarn "it will generate lots of noise and an oddity here and there."
ewarn "see http://trac.sagemath.org/sage_trac/ticket/11334 for details"
Please sign in to comment.
Something went wrong with that request. Please try again.