Small scripts to benchmark the different backend available for kittystore
Python R
Pull request Compare This branch is 2 commits ahead, 1 commit behind pypingou:master.
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
kittystore
output_el6
output_f17
.gitignore
README.rst
add_fulltext_index.py
tests.py
visualisation.R

README.rst

KittyBenchmark

Author: Pierre-Yves Chibon <pingou@pingoured.fr>

Scripts used to run a benchmark using kittystore against the backends:

  • postgresql (8.4.9-1.el6_1.1.x86_64)
  • mongodb (1.8.2-2.el6.x86_64)

Get this project:

Source: https://github.com/pypingou/kittybenchmark

Dependencies:

  • kittystore (Bundled in)
  • SQLAlchemy
  • pymongo for mongodb
  • R

We now have a modified version of kittystore which contains more queries for PostgreSQL. Modified queries which will not be part of upstream's version (for example, using union or 'or' statement). Use the version bundled in, or you will have to adjust tests.py

Usage:

Clone this repository:
git clone https://github.com/pypingou/kittybenchmark.git
Adjust the tests.py file:
At the top of the file, adjust the lines 12 (URL) and 14 (MG_STORE), replace the dummy information with the real information needed to connect to the databases.
Run the script:
python tests.py
Generate the visualisation:
R < visualisation.R

License

KittyBenchmark is licensed under the GPL v2.0