Ubuntu 16.10 crash. #452

Open
michelinok opened this Issue Nov 17, 2016 · 13 comments

Projects

None yet

6 participants

@michelinok

Hi!
I'm not able to run gqrx from Ubuntu 16.10 fresh install.
Tryed from sources and from package via pt-get install gqrx-sdr.
It always crash with segafult when i try to run it

[ 345.079830] gqrx[4235]: segfault at 1 ip 00007f7d9f00c188 sp 00007fff052da390 error 4 in libgnuradio-blocks.so.3.7.10[7f7d9ee91000+2bc000]

Any idea?

@csete
Owner
csete commented Nov 17, 2016

Hi @michelinok

Please see this thread:
https://groups.google.com/forum/#!msg/gqrx/eqAcCAg0i84/8qNdJkJKBgAJ

and this bug report:
https://bugs.launchpad.net/ubuntu/+source/gqrx-sdr/+bug/1637774

Could you please try the AppImage and see if it works for you?

@csete
Owner
csete commented Nov 21, 2016

Any luck with the AppImage?

@michelinok

OMG...didn't see your answer :°(
I'll try again on another machine as soon as i can (i've reinstalled my machine with 16.04 due to an emergency in the gqrx usage).
I'll let you know if it works as soon as i get to my office (monday)

Sorry for the late response.

'73 de IU5HES

@csete
Owner
csete commented Nov 23, 2016

No problem. If you can use 16.04 it's fine :-)

@michelinok

yes...but you've wasted time answering... :°(

@rhaamo
rhaamo commented Nov 27, 2016

Hi.

I may have the same problem.
I've got the segfault using the package then I tried to build from latest git master and same segfault problem.

I have tried the AppImage Gqrx-2.5.3.glibc2.17-x86_64.AppImage but I get:

/bin/bash: ../lib/x86_64-linux-gnu/libtinfo.so.5: no version information available (required by /bin/bash)
linux; GNU C++ version 4.8.4; Boost_105400; UHD_003.010.000.000-release

Gtk-Message: Failed to load module "atk-bridge"
/tmp/.mount_ENKL9X/usr/bin/gqrx-sdr: symbol lookup error: /usr/lib/x86_64-linux-gnu/libpangoft2-1.0.so.0: undefined symbol: hb_buffer_set_cluster_level

Any hints or things to try about the segfault issue ?

@csete
Owner
csete commented Nov 27, 2016

Hi @rhaamo

There is a v2.6 AppImage: https://github.com/csete/gqrx/releases/tag/v2.6
Please try that.

I hope the main issue will be resolved in Ubuntu, see the linked bug report.

As I wrote on the mailing list, a workaround could be to build gr-osmosdr without UHD support then rebuild gqrx with the new gr-osmosdr

@rhaamo
rhaamo commented Nov 27, 2016

No luck with the AppImage, same error.
I've rebuilt gr-osmosdr package without UHD and it's OK.

Thanks !

@csete
Owner
csete commented Nov 27, 2016

Thanks for trying :-)

I didn't have time to try it myself, so I'm glad to know that this workaround does work.

@dennisheitmann

Does it mean that gr-osmosdr is broken or just incompatible with the current version of gqrx? Which steps at Ubuntu (or anywhere else) are necessary to repair the situation? For which package I have to e.g. file a bug report?
Many thanks in advance.

@csete
Owner
csete commented Jan 9, 2017

@dennisheitmann please see my comment from Nov 2016: #452 (comment)

The problem occurs in the UHD library, which is the driver for Ettus USRP devices. The problem will affect anything that links to this library, including gr-osmosdr and gqrx. Ettus has been trying to upload new packages to their PPA so that we can use them until Ubuntu is updated (I think there is a link in the email thread) but they have been having problems with the PPA.

@m1geo
m1geo commented Jan 10, 2017

Same as @rhaamo, No luck with Gqrx-2.6-1.glibc2.17-x86_64.AppImage.

george@watt:~/Desktop$ ./Gqrx-2.6-1.glibc2.17-x86_64.AppImage
linux; GNU C++ version 4.8.4; Boost_105400; UHD_003.010.001.000-release

./Gqrx-2.6-1.glibc2.17-x86_64.AppImage: symbol lookup error: /usr/lib/x86_64-linux-gnu/libpangoft2-1.0.so.0: undefined symbol: hb_buffer_set_cluster_level
george@watt:~/Desktop$

Ah well, that idea can wait for a while then! Thanks for your hard work @csete de M1GEO

@lnx64
lnx64 commented Jan 14, 2017

Hopefully this will get fixed soon. I'm a first responder and use this software to listen to different frequencies across the spectrum quickly, and I'm stuck between a rock and a hard place. I need 16.10 to fix a Chrome issue with Intel GPU's (the drivers are not being backported to fix it), and I need gqrx to work, so I have to stay with 16.04 as it has priority right now.

I understand it's not gqrx's fault really, but the other devs need to hurry up, 17.04 will be out soon.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment