A library for executing AppleScript in Dart.
Switch branches/tags
Nothing to show
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
example
lib
.gitignore
CHANGELOG.md
LICENSE
README.md
pubspec.yaml

README.md

applescript

A library for executing AppleScript in Dart.

Usage

A simple usage example:

import 'package:applescript/applescript.dart';
import 'dart:io'; // required for results callback

main() {
  // Example
  AppleScript as = new AppleScript('tell application "Spotify" to playpause');
  as.run();
  
  // Example with Results Callback
  printResults(ProcessResult results) {
    print(results.stdout);
  }
  
  AppleScript as2 = new AppleScript.results('do shell script "echo Hello World"', printResults);
  as2.run();
}

Features and bugs

Please file feature requests and bugs at the issue tracker.