New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

seti_ui breaks sublime text, black window "osx mojave" #304

Open
webrender opened this Issue Oct 19, 2018 · 9 comments

Comments

3 participants
@webrender

webrender commented Oct 19, 2018

What version of ST are you using? (nothing lower than 3103).

3176

Have you restarted ST after you installed the theme?

Yes

If you still have bad render, have you removed the cache folder (found right next to the packages folder)?

Yes

Extra Info "attaching a screen shot would be very helpful"

screen shot 2018-10-19 at 10 47 28 am

removing the package, or resetting the theme in preferences, fixes ST.

@ctf0

This comment has been minimized.

Owner

ctf0 commented Oct 19, 2018

am using it on windows with v3176 and mac with v3180 and in both the theme is working fine, check the console to see what exactly is causing this

@webrender

This comment has been minimized.

webrender commented Oct 19, 2018

unfortunately when i select the theme, everything disappears, including the console. is there a way i can open the console output in another application?

@ctf0

This comment has been minimized.

Owner

ctf0 commented Oct 19, 2018

as far as i know each window have its own console, so opening another window with a different theme wont help.

@webrender

This comment has been minimized.

webrender commented Oct 19, 2018

upon doing some more experimentation, this appears to be linked to the title_bar properties - removing all references from the theme file fixes the functionality.

When I tried specifying the title bar color in another theme, the same thing happened, so it seems like this is related to ST or possibly Mac OS, and not the seti theme. Feel free to close this unless you'd like to keep it open for others experiencing similar issues.

@ctf0

This comment has been minimized.

Owner

ctf0 commented Oct 19, 2018

i think what u need is "Seti_use_system_title_bar": false, however on my system osx 10.11.6 / st 3180 toggling it to true or false doesnt produce the issue u r having

@ctf0 ctf0 added the question label Oct 19, 2018

@ctf0 ctf0 closed this Oct 19, 2018

@webrender

This comment has been minimized.

webrender commented Oct 19, 2018

"Seti_use_system_title_bar": true, fixed it for me. not sure what's going on there, i just performed a system update before this happened so it may be related. (osx 10.14.1 Beta (18B67a))

@webrender

This comment has been minimized.

webrender commented Oct 19, 2018

more info + fix here: https://forum.sublimetext.com/t/sublimetext-3180-turned-into-totally-dark-after-mojave-upgraded-to-10-14-1-beta/39901/10

By editting the preference file to set following:
"gpu_window_buffer": false,
will make sublimetext work for now. The file was located at Library/Application Support/Sublime Text 3/Packages/User/Preferences.sublime-settings

@ctf0

This comment has been minimized.

Owner

ctf0 commented Oct 19, 2018

i think this answer sums the reason behind the issue

@ctf0 ctf0 changed the title from seti_ui breaks sublime text, black window to seti_ui breaks sublime text, black window "osx mojave" Oct 19, 2018

@ctf0 ctf0 reopened this Oct 23, 2018

@ctf0 ctf0 added the invalid label Oct 23, 2018

@wongyongcheng

This comment has been minimized.

wongyongcheng commented Oct 26, 2018

thanks

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment