Installation

Jens Reimann edited this page Feb 6, 2015 · 6 revisions

Ubuntu 14.04

Install Java 8

Installing Java 8 on Ubuntu 14.04 is quite a mess. There is one way to do this like the installation of the Adobe Flash plugin. A wrapper package is installed, which downloads the official Oracle JDK and installs this locally. There is an explanation right here: http://tecadmin.net/install-oracle-java-8-jdk-8-ubuntu-via-ppa/

Hopefully there will be easier ways in the future.

Note: Ubuntu 14.10 comes with openjdk-8. First tests show, it seems to work.

Add repository

This step is only required once. It will add the APT repository to your system.

Install the package signing key:

sudo apt-key adv --keyserver hkp://keys.gnupg.net --recv-keys 97A336A9320E6224

And create a new file to add the repository /etc/apt/sources.list.d/PackageDrone.list:

deb http://repo.dentrassi.de/apt package-drone main

You can use the following command for creating the file:

sudo sh -c "echo deb http://repo.dentrassi.de/apt package-drone main > /etc/apt/sources.list.d/PackageDrone.list"

Installing the package

Refresh the package cache before installing:

sudo apt-get update

And then install the package:

sudo apt-get install package-drone-server

Starting and stopping

Package Drone uses upstart on Ubuntu.

Start package drone by:

$ sudo start package-drone-server

Stop package drone by:

$ sudo stop package-drone-server

Uninstalling

Uninstall package drone:

sudo dpkg --purge package-drone-server

CentOS 6 / 7

Install Java 8

Installing Java 8 on CentOS is no better. There are official packages of Java 8 from Oracle: https://www.java.com Be sure to download the right (JRE is ok) version and install it using RPM.

This is easier than Ubuntu. However the name of the RPM package contains the version of Java. Instead of providing "jre" with version 1.8.x, they provide "jre-1.8.x" with version 1.8.x.

Adding a dependency impossible that way, since it would force one to reference a jre with a specific version. Once an updated version is available, you could not install package drone with that newer version. So it is not possible to add any (reasonable) dependency at all on CentOS (and RHEL).

Add repository

This step is only required once. It will add the YUM repository to your system.

Create a new file /etc/yum.repos.d/pdrone.repo.

For CentOS 7:

[PackageDrone]
name=Package Drone Repository
baseurl=http://repo.dentrassi.de/yum/centos/7
enabled=1
gpgcheck=1
gpgkey=http://repo.dentrassi.de/PD-GPG-KEY

For CentOS 6:

[PackageDrone]
name=Package Drone Repository
baseurl=http://repo.dentrassi.de/yum/centos/6
enabled=1
gpgcheck=1
gpgkey=http://repo.dentrassi.de/PD-GPG-KEY

Install package

Run as root:

# yum install package-drone-server

The first time it will ask you if you want to import the GPG used for signing Package Drone. You need to answer "yes" or disable the GPG check instead.

Firewall

In CentOS 7 the firewall is automatically configured to open the required port.

In CentOS 6 the firewall must be manually configured to open port 8080. This can be done by executing the following command as root:

lokkit -q -p 8080:tcp

Uninstalling

In order to uninstall Package Drone issue the following command:

# rpm -e package-drone-server

Initial setup

Follow the instruction to setup of the system. Of course you can skip the installation of the software.

Signing Key

The package and repository signing key is at: http://repo.dentrassi.de/PD-GPG-KEY

-----BEGIN PGP PUBLIC KEY BLOCK-----
Version: GnuPG v1
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=7lcE
-----END PGP PUBLIC KEY BLOCK-----

You can’t perform that action at this time.
You signed in with another tab or window. Reload to refresh your session. You signed out in another tab or window. Reload to refresh your session.
Press h to open a hovercard with more details.