Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Server only starts on IPv6 #4351

Open
jdek opened this issue Jul 10, 2019 · 3 comments

Comments

@jdek
Copy link

@jdek jdek commented Jul 10, 2019

Client version: 1.12.2
Server OS: OpenBSD 6.5 amd64
Commit id: 9dc1343

Expected behaviour

Cuberite to listen on both IPv4 and IPv6.

Actual behaviour

Cuberite only listens on IPv6.

tcp6         0      0  *.25565                *.*                    LISTEN

Steps to reproduce the behaviour

Just ./Cuberite with default config.

There's no way to specify hostname (i.e. if I have many domains mapped to the same IP), or IP protocol (i.e. if IPv6 is supported but you really want it to use IPv4 instead).

@jdek

This comment has been minimized.

Copy link
Author

@jdek jdek commented Jul 10, 2019

I'll fix it and make a PR.

@Bjornskjald

This comment has been minimized.

Copy link

@Bjornskjald Bjornskjald commented Aug 27, 2019

Actually, while it showed in netstat it listens only on v6, I almost always could connect with regular v4 connection. Maybe you could check your firewall settings?

@jdek

This comment has been minimized.

Copy link
Author

@jdek jdek commented Sep 9, 2019

It wasn't a firewall issue, it was just only starting a socket on v6. Sorry, I haven't had a chance to fix it yet, and I'm not sure when I will since I've taken a bit of a hiatus from playing minecaft.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.