Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

SATA not working on r5? #100

Closed
supermarioprof opened this issue Sep 9, 2013 · 7 comments
Closed

SATA not working on r5? #100

supermarioprof opened this issue Sep 9, 2013 · 7 comments
Labels

Comments

@supermarioprof
Copy link

@supermarioprof supermarioprof commented Sep 9, 2013

I'm not able to have SATA working with r5.
I dd to SD, then lsmod but nothing about SATA is showed, while /etc/modules contains SATA modules.
So what?

@cubieplayer
Copy link
Owner

@cubieplayer cubieplayer commented Sep 9, 2013

Sry, I just fixed the problem. The problem only happens on A10 which is caused by a wrong configuration of script.bin mmplayer/sunxi-boards@7bb2fea

@cubieplayer
Copy link
Owner

@cubieplayer cubieplayer commented Sep 9, 2013

Forget to mention how to solve it

apt-get install cubian-update
cubian-update

should do the trick

@s-kostyuk
Copy link

@s-kostyuk s-kostyuk commented Sep 9, 2013

Many thanks :)

@hawk0107
Copy link

@hawk0107 hawk0107 commented Sep 14, 2013

Hi all, Today (September14th) the fixed script.bin will not be downloaded by the cubian-update. the version is from September 4th. But the fix from September 9th. I fixed it by modifing the script.fex file on /boot (mmplayer/sunxi-boards@7bb2fea) and with that created the modified script.bin with fex2bin (https://www.olimex.com/forum/index.php?topic=184.0).

@cubieplayer
thank you very much for your great work on cubian.
You only need to check why there is no new script.bin downloaded by cubian-update

@cubieplayer
Copy link
Owner

@cubieplayer cubieplayer commented Sep 17, 2013

@hawk0107 Hi, the script.bin is not updated because you needs to update the cubian-update itself to newer version. For current is v1.1.1

apt-get update
apt-get install cubian-update

@hawk0107
Copy link

@hawk0107 hawk0107 commented Sep 17, 2013

Hi cubieplayer,

apt-get install cubian-update tells me:
cubian-update is already the newest version.

I checked the cubian-update script. I already had Version 1.1.1

But when i started cubian-update again it updated the script.bin today. And the sata hdd works with the script.bin from the server. :-)

I do not know why it didn´t work in the first place. But more important is, that it works now.
Thank you for this updater.

@michalliu michalliu closed this Oct 2, 2013
@cubieplayer
Copy link
Owner

@cubieplayer cubieplayer commented Nov 2, 2013

You need to use the following command to update the script.bin.

cubian-update --update-board-cfg

If there is no updates for you, you needs to run

cubian-update --update-board-cfg --reinstall

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
5 participants
You can’t perform that action at this time.