Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

FileUtils required by Aruba makes a broken gem pass a test #115

Closed
awendt opened this Issue · 2 comments

2 participants

@awendt

Hi,

I just stumbled upon the following problem in my poet gem: I get a NameError on the constant FileUtils that I didn't require. No problem, add the missing require, problem solved.

But why does the test pass when the gem is broken? I suspect this is because Aruba and Cucumber themselves require "fileutils".

Can that really be the problem here? And if so, is it possible to change that behavior so that programs are run as if I would run them myself?

Thanks,
André

@mattwynne
Owner

I don't understand how this could be. Aruba runs your commands out of process, so it's a new Ruby process.

Could it be something to do with different Ruby versions?

@mattwynne
Owner

Closing due to inactivity. Please reopen if still relevant.

@mattwynne mattwynne closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.