Because of rdiscount, aruba does not run on JRuby #85

Closed
simonharrer opened this Issue Aug 26, 2011 · 3 comments

Comments

Projects
None yet
4 participants
Contributor

simonharrer commented Aug 26, 2011

Hi folks,

really cool gem you have! However, I cannot install it under JRuby, as you are using rdiscount, which is a gem with quite some c code.

My suggestion is to provide an additional aruba gem which only provides the CLI testing functionality and another gem called aruba-reporting which includes the reporting.

New suggested structure:
aruba-core
aruba-reporting
aruba

Thus, when on windows, you would only need to require aruba-core. All posix people can require aruba which requires aruba-core and aruba-reporting. This should be somewhat backward compatible.

Cheers,
Simon

kaiwren commented Oct 14, 2011

+1 - we have an un-runnable build on RSpec on JRuby because of this /cc @justinko @yawn

Owner

mattwynne commented Nov 3, 2011

Owner

aslakhellesoy commented Nov 3, 2011

I'll remove the dep...

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment