Skip to content

Getting skipped tests on windows, fine on Mac #139

Closed
fatlazycat opened this Issue Jan 15, 2012 · 5 comments

2 participants

@fatlazycat

Using cuke-jvm RC3 I get get skipped tests when I attempt run on windows. The same maven project on a mac execute fine and the test run and pass from the basic arithmetic example.

This sample is just a copy of your scala / java examples.

I got a similar behaviour when I attempted to run the examples on windows when in the actual example directory. The examples still reference RC2 by the way.

Is this known issue ??

@aslakhellesoy
Cucumber member

This is too vague. You're not saying how you run things. I don't know any of your files, your output etc.

@fatlazycat

Sorry about that, have put it in fatlazycat/samples

Then cd sbe and run mvn test. Currently using mvn 3.0.3, Java 1.6.0_30 and Scala 2.9.1

@fatlazycat

Under mac get 3 run tests, under windows 3 tests are run but the scenarios don't get tested and just report 2 skipped tests

@aslakhellesoy
Cucumber member

Thanks for the details. I have reproduced it and am looking into it.

@aslakhellesoy aslakhellesoy pushed a commit that referenced this issue Jan 16, 2012
DFUK Scala fixes for Windows. #139 4e3d258
@aslakhellesoy
Cucumber member

This is fixed on master - will be fixed in the next release.

@aslakhellesoy aslakhellesoy added a commit that referenced this issue Jan 16, 2012
@aslakhellesoy aslakhellesoy Added history for #139 70d2e9d
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.