Skip to content
Permalink
Browse files

Add project metadata to the gemspec (#447)

* Add project metadata to the gemspec

As per https://guides.rubygems.org/specification-reference/#metadata,
add metadata to the gemspec file. This'll allow people to more easily
access the source code, raise issues and read the changelog. These links
will appear on the rubygems page at
https://rubygems.org/gems/cucumber-rails and be available via the
rubygems API after the next release.

* Remove wiki URI
  • Loading branch information
orien authored and olleolleolle committed Nov 4, 2019
1 parent c618f55 commit 23e141c220cfd68b5ea8ce1872ad8fb10bf12c27
Showing with 9 additions and 1 deletion.
  1. +9 −1 cucumber-rails.gemspec
@@ -9,10 +9,18 @@ Gem::Specification.new do |s|
s.description = 'Cucumber Generator and Runtime for Rails'
s.summary = "#{s.name}-#{s.version}"
s.email = 'cukes@googlegroups.com'
s.homepage = 'http://cukes.info'
s.homepage = 'https://cucumber.io'

s.license = 'MIT'

s.metadata = {
'bug_tracker_uri' => 'https://github.com/cucumber/cucumber-rails/issues',
'changelog_uri' => "https://github.com/cucumber/cucumber-rails/blob/v#{s.version}/CHANGELOG.md",
'documentation_uri' => 'https://cucumber.io/docs',
'mailing_list_uri' => 'https://groups.google.com/forum/#!forum/cukes',
'source_code_uri' => "https://github.com/cucumber/cucumber-rails/tree/v#{s.version}"
}

s.add_runtime_dependency('capybara', ['>= 2.12', '< 4'])
s.add_runtime_dependency('cucumber', ['>= 3.0.2', '< 4'])
s.add_runtime_dependency('mime-types', ['>= 2.0', '< 4'])

0 comments on commit 23e141c

Please sign in to comment.
You can’t perform that action at this time.