Skip to content
This repository
tag: v0.10.2
Fetching contributors…

Cannot retrieve contributors at this time

file 57 lines (48 sloc) 2.259 kb
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57
# -*- encoding: utf-8 -*-
$LOAD_PATH.unshift File.expand_path("../lib", __FILE__)
require "cucumber/platform"

Gem::Specification.new do |s|
  s.name = 'cucumber'
  s.version = Cucumber::VERSION
  s.authors = ["Aslak Hellesøy"]
  s.description = 'Behaviour Driven Development with elegance and joy'
  s.summary = "cucumber-#{s.version}"
  s.email = 'cukes@googlegroups.com'
  s.homepage = "http://cukes.info"

  s.platform = Gem::Platform::RUBY
  s.default_executable = "cucumber"
  s.post_install_message = %{
(::) (::) (::) (::) (::) (::) (::) (::) (::) (::) (::) (::) (::) (::) (::)

Thank you for installing cucumber-#{Cucumber::VERSION}.
Please be sure to read http://wiki.github.com/aslakhellesoy/cucumber/upgrading
for important information about this release. Happy cuking!

(::) (::) (::) (::) (::) (::) (::) (::) (::) (::) (::) (::) (::) (::) (::)

}

  s.add_dependency 'gherkin', '>= 2.3.5'
  s.add_dependency 'term-ansicolor', '>= 1.0.5'
  s.add_dependency 'builder', '>= 2.1.2'
  s.add_dependency 'diff-lcs', '>= 1.1.2'
  s.add_dependency 'json', '>= 1.4.6'
  
  s.add_development_dependency 'aruba', '>= 0.3.4'
  s.add_development_dependency 'rake', '>= 0.8.7'
  s.add_development_dependency 'rspec', '>= 2.5.0'
  s.add_development_dependency 'nokogiri', '>= 1.4.4'
  s.add_development_dependency 'prawn', '= 0.8.4'
  s.add_development_dependency 'prawn-layout', '= 0.8.4'
  s.add_development_dependency 'syntax', '>= 1.0.0'
  s.add_development_dependency 'spork', '>= 0.8.4'
  s.add_development_dependency 'simplecov', '>= 0.4.1'
  
  # Needed for examples (rake examples)
  s.add_development_dependency 'ramaze'
  s.add_development_dependency 'rack-test', '>= 0.5.7'
  s.add_development_dependency 'webrat', '>= 0.7.3'
  s.add_development_dependency 'sinatra', '>= 1.2.0'
  s.add_development_dependency 'capybara', '>= 0.4.1'

  s.rubygems_version = ">= 1.6.1"
  s.files = `git ls-files`.split("\n")
  s.test_files = `git ls-files -- {spec,features}/*`.split("\n")
  s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
  s.extra_rdoc_files = ["LICENSE", "README.rdoc", "History.txt"]
  s.rdoc_options = ["--charset=UTF-8"]
  s.require_path = "lib"
end
Something went wrong with that request. Please try again.