Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

We’re showing branches in this repository, but you can also compare across forks.

base fork: cucumber/cucumber
...
head fork: cucumber/cucumber
  • 1 commit
  • 4 files changed
  • 0 commit comments
  • 1 contributor
Commits on Apr 21, 2010
Aslak Hellesøy aslakhellesoy Release 0.7.0.beta.2 57a70f0
Showing with 13 additions and 8 deletions.
  1. +5 −0 History.txt
  2. +1 −1  Rakefile
  3. +1 −1  VERSION.yml
  4. +6 −6 cucumber.gemspec
5 History.txt
View
@@ -1,3 +1,8 @@
+== 0.7.0.beta.2 (2010-04-21)
+
+=== New Features
+* Depend on Gherkin 1.0.18, which has some bugfixes. (Aslak Hellesøy)
+
== 0.7.0.beta.1 (2010-04-20)
Treetop is gone and replaced with Ragel. The new Ragel parser lives in the gherkin gem.
2  Rakefile
View
@@ -16,7 +16,7 @@ begin
gem.homepage = "http://cukes.info"
gem.authors = ["Aslak Hellesøy"]
- gem.add_dependency 'gherkin', '= 1.0.16'
+ gem.add_dependency 'gherkin', '= 1.0.18'
gem.add_dependency 'term-ansicolor', '>= 1.0.4'
gem.add_dependency 'builder', '>= 2.1.2'
gem.add_dependency 'diff-lcs', '>= 1.1.2'
2  VERSION.yml
View
@@ -1,5 +1,5 @@
---
:patch: 0
-:build: beta.1
+:build: beta.2
:major: 0
:minor: 7
12 cucumber.gemspec
View
@@ -5,11 +5,11 @@
Gem::Specification.new do |s|
s.name = %q{cucumber}
- s.version = "0.7.0.beta.1"
+ s.version = "0.7.0.beta.2"
s.required_rubygems_version = Gem::Requirement.new("> 1.3.1") if s.respond_to? :required_rubygems_version=
s.authors = ["Aslak Helles\303\270y"]
- s.date = %q{2010-04-20}
+ s.date = %q{2010-04-21}
s.default_executable = %q{cucumber}
s.description = %q{A BDD tool written in Ruby}
s.email = %q{cukes@googlegroups.com}
@@ -537,7 +537,7 @@ Gem::Specification.new do |s|
(::) U P G R A D I N G (::)
-Thank you for installing cucumber-0.7.0.beta.1.
+Thank you for installing cucumber-0.7.0.beta.2.
Please be sure to read http://wiki.github.com/aslakhellesoy/cucumber/upgrading
for important information about this release. Happy cuking!
@@ -714,7 +714,7 @@ for important information about this release. Happy cuking!
s.specification_version = 3
if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<gherkin>, ["= 1.0.16"])
+ s.add_runtime_dependency(%q<gherkin>, ["= 1.0.18"])
s.add_runtime_dependency(%q<term-ansicolor>, [">= 1.0.4"])
s.add_runtime_dependency(%q<builder>, [">= 2.1.2"])
s.add_runtime_dependency(%q<diff-lcs>, [">= 1.1.2"])
@@ -727,7 +727,7 @@ for important information about this release. Happy cuking!
s.add_development_dependency(%q<syntax>, [">= 1.0.0"])
s.add_development_dependency(%q<spork>, [">= 0.7.5"])
else
- s.add_dependency(%q<gherkin>, ["= 1.0.16"])
+ s.add_dependency(%q<gherkin>, ["= 1.0.18"])
s.add_dependency(%q<term-ansicolor>, [">= 1.0.4"])
s.add_dependency(%q<builder>, [">= 2.1.2"])
s.add_dependency(%q<diff-lcs>, [">= 1.1.2"])
@@ -741,7 +741,7 @@ for important information about this release. Happy cuking!
s.add_dependency(%q<spork>, [">= 0.7.5"])
end
else
- s.add_dependency(%q<gherkin>, ["= 1.0.16"])
+ s.add_dependency(%q<gherkin>, ["= 1.0.18"])
s.add_dependency(%q<term-ansicolor>, [">= 1.0.4"])
s.add_dependency(%q<builder>, [">= 2.1.2"])
s.add_dependency(%q<diff-lcs>, [">= 1.1.2"])

No commit comments for this range

Something went wrong with that request. Please try again.