No lexer was found for en #154

Closed
rajcybage opened this Issue Feb 4, 2016 · 2 comments

Projects

None yet

2 participants

@rajcybage

I have
C:/RailsInstaller/Ruby2.1.0/lib/ruby/gems/2.1.0/gems/gherkin-2.12.2-x86-mingw32

C:/RailsInstaller/Ruby2.1.0/lib/ruby/2.1.0/i386-mingw32. Reverting to Ruby lexer.
C:/RailsInstaller/Ruby2.1.0/lib/ruby/gems/2.1.0/gems/gherkin-2.12.2-x86-mingw32/lib/gherkin/i18n.rb:108:in `rescue in lexer': No lexer was found for en (cannot load such file -- gherkin/lexer
ported languages are listed in gherkin/i18n.json. (Gherkin::I18n::LexerNotFound)
        from C:/RailsInstaller/Ruby2.1.0/lib/ruby/gems/2.1.0/gems/gherkin-2.12.2-x86-mingw32/lib/gherkin/i18n.rb:97:in `lexer'
        from C:/RailsInstaller/Ruby2.1.0/lib/ruby/gems/2.1.0/gems/gherkin-2.12.2-x86-mingw32/lib/gherkin/parser/parser.rb:139:in `transition_table'
        from C:/RailsInstaller/Ruby2.1.0/lib/ruby/gems/2.1.0/gems/gherkin-2.12.2-x86-mingw32/lib/gherkin/parser/parser.rb:128:in `build_transition_map'
        from C:/RailsInstaller/Ruby2.1.0/lib/ruby/gems/2.1.0/gems/gherkin-2.12.2-x86-mingw32/lib/gherkin/parser/parser.rb:124:in `transition_map'
        from C:/RailsInstaller/Ruby2.1.0/lib/ruby/gems/2.1.0/gems/gherkin-2.12.2-x86-mingw32/lib/gherkin/parser/parser.rb:91:in `initialize'
        from C:/RailsInstaller/Ruby2.1.0/lib/ruby/gems/2.1.0/gems/gherkin-2.12.2-x86-mingw32/lib/gherkin/parser/parser.rb:68:in `new'
        from C:/RailsInstaller/Ruby2.1.0/lib/ruby/gems/2.1.0/gems/gherkin-2.12.2-x86-mingw32/lib/gherkin/parser/parser.rb:68:in `push_machine'
        from C:/RailsInstaller/Ruby2.1.0/lib/ruby/gems/2.1.0/gems/gherkin-2.12.2-x86-mingw32/lib/gherkin/parser/parser.rb:31:in `parse'
        from C:/RailsInstaller/Ruby2.1.0/lib/ruby/gems/2.1.0/gems/turnip-2.0.2/lib/turnip/builder.rb:124:in `block in build'
        from C:/RailsInstaller/Ruby2.1.0/lib/ruby/gems/2.1.0/gems/turnip-2.0.2/lib/turnip/builder.rb:122:in `tap'
        from C:/RailsInstaller/Ruby2.1.0/lib/ruby/gems/2.1.0/gems/turnip-2.0.2/lib/turnip/builder.rb:122:in `build'
        from C:/RailsInstaller/Ruby2.1.0/lib/ruby/gems/2.1.0/gems/turnip-2.0.2/lib/turnip/rspec.rb:67:in `run'
        from C:/RailsInstaller/Ruby2.1.0/lib/ruby/gems/2.1.0/gems/turnip-2.0.2/lib/turnip/rspec.rb:18:in `load'
        from C:/RailsInstaller/Ruby2.1.0/lib/ruby/gems/2.1.0/gems/rspec-core-3.4.2/lib/rspec/core/configuration.rb:1361:in `block in load_spec_files'
        from C:/RailsInstaller/Ruby2.1.0/lib/ruby/gems/2.1.0/gems/rspec-core-3.4.2/lib/rspec/core/configuration.rb:1359:in `each'
        from C:/RailsInstaller/Ruby2.1.0/lib/ruby/gems/2.1.0/gems/rspec-core-3.4.2/lib/rspec/core/configuration.rb:1359:in `load_spec_files'
        from C:/RailsInstaller/Ruby2.1.0/lib/ruby/gems/2.1.0/gems/rspec-core-3.4.2/lib/rspec/core/runner.rb:106:in `setup'
        from C:/RailsInstaller/Ruby2.1.0/lib/ruby/gems/2.1.0/gems/rspec-core-3.4.2/lib/rspec/core/runner.rb:92:in `run'
        from C:/RailsInstaller/Ruby2.1.0/lib/ruby/gems/2.1.0/gems/rspec-core-3.4.2/lib/rspec/core/runner.rb:78:in `run'
        from C:/RailsInstaller/Ruby2.1.0/lib/ruby/gems/2.1.0/gems/rspec-core-3.4.2/lib/rspec/core/runner.rb:45:in `invoke'
        from C:/RailsInstaller/Ruby2.1.0/lib/ruby/gems/2.1.0/gems/rspec-core-3.4.2/exe/rspec:4:in `<top (required)>'
        from C:/RailsInstaller/Ruby2.1.0/bin/rspec:23:in `load'

@aslakhellesoy
Member

Please upgrade to Cucumber 2.1 or later, which uses gherkin 3, where this bug is fixed.

@rajcybage

I am using turnip 2.0.2 but get the error they already open jnicklas/turnip#171

@tute tute added a commit to thoughtbot/paperclip that referenced this issue Oct 28, 2016
@tute tute Upgrade cucumber 204095f
@tute tute added a commit to thoughtbot/paperclip that referenced this issue Oct 28, 2016
@tute tute Upgrade cucumber 8a2647c
@tute tute referenced this issue in thoughtbot/paperclip Oct 28, 2016
Merged

Fix Travis CI #2331

@tute tute added a commit to thoughtbot/paperclip that referenced this issue Oct 28, 2016
@tute tute Upgrade cucumber 771f018
@tute tute added a commit to thoughtbot/paperclip that referenced this issue Oct 28, 2016
@tute tute Upgrade cucumber 92d9b90
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment