Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
46 lines (27 sloc) 1.781 kB

Getting wire.js

Wire.js requires an AMD compatible loader and an ES5 environment when running in a browser. If you aren't already using an AMD loader and ES5 shim, we recommend curl and poly. Other AMD loaders, such as RequireJS, and ES5 shims, such as es5-shim, should work as well.

Yeoman/Bower

yeoman install wire or bower install wire

Node

npm install wire

RingoJS

  1. ringo-admin install cujojs/wire
  2. ringo-admin install cujojs/when
  3. ringo-admin install cujojs/meld

Clone

  1. git clone https://github.com/cujojs/wire
  2. cd wire
  3. git submodule init && git submodule update
    • NOTE: poly is included as a submodule, so you won't need to download it separately if you install wire.js this way.

Download

Download each of the following and arrange into your project:

  1. wire
  2. when >= 1.5.0
  3. meld >= 1.0.0

Other libraries

Getting curl

To use curl as your AMD loader, wire.js 0.9.x requires curl 0.7.1 or higher, or 0.6.8. You can clone or download curl into your project, or install it via yeoman/bower:

yeoman install curl or bower install curl

Getting poly

To support non-ES5 legacy browsers, wire.js requires poly 0.5.0 or higher. You can clone or download poly into your project, or install it via yeoman/bower:

yeoman instal poly or bower install poly

Jump to Line
Something went wrong with that request. Please try again.