Skip to content
Permalink
Browse files

curl-functions.m4: remove inappropriate AC_REQUIRE

AC_REQUIRE means "if this macro hasn't been executed already, execute
it".  So in a wrapper around AC_RUN_IFELSE, AC_REQUIRE(AC_RUN_IFELSE)
isn't correct at that will execute AC_RUN_IFELSE without any arguments.

With autoconf 2.69 this is basically a no-op, but with autoconf 2.70,
AC_RUN_IFELSE without a default value when cross-compiling is fatal.
The result is that curl with autoconf 2.70 cannot cross-compile.

Fixes #5126
Closes #5130
  • Loading branch information
rossburton authored and jay committed Mar 20, 2020
1 parent 9b4990f commit f25f602ffd026cc6b5bb0b3a6d8f1abe1bad7881
Showing with 0 additions and 2 deletions.
  1. +0 −2 m4/curl-functions.m4
@@ -7289,8 +7289,6 @@ dnl CURL_LIBRARY_PATH variable. It keeps the LD_LIBRARY_PATH
dnl changes contained within this macro.
AC_DEFUN([CURL_RUN_IFELSE], [
AC_REQUIRE([AC_RUN_IFELSE])dnl
old=$LD_LIBRARY_PATH
LD_LIBRARY_PATH=$CURL_LIBRARY_PATH:$old
export LD_LIBRARY_PATH

0 comments on commit f25f602

Please sign in to comment.
You can’t perform that action at this time.