travis: bump to llvm toolchain 6.0 #2478

Closed
wants to merge 2 commits into
from

Conversation

Projects
None yet
2 participants
@bagder
Member

bagder commented Apr 9, 2018

No description provided.

@MarcelRaad

This comment has been minimized.

Show comment Hide comment
@MarcelRaad

MarcelRaad Apr 9, 2018

Member

If your goal is to use clang 6, you also have to update the package version as currently clang 3.9 is still used. For this, you have to wait for (or incorporate) #2476 which I want to merge tomorrow morning. And while you're at it, you could also update GCC to 7 then, which also requires trusty :-)

Member

MarcelRaad commented Apr 9, 2018

If your goal is to use clang 6, you also have to update the package version as currently clang 3.9 is still used. For this, you have to wait for (or incorporate) #2476 which I want to merge tomorrow morning. And while you're at it, you could also update GCC to 7 then, which also requires trusty :-)

@bagder

This comment has been minimized.

Show comment Hide comment
@bagder

bagder Apr 9, 2018

Member

Yes, that's exactly where I want to go... =)

Member

bagder commented Apr 9, 2018

Yes, that's exactly where I want to go... =)

@bagder

This comment has been minimized.

Show comment Hide comment
@bagder

bagder Apr 9, 2018

Member

I'll await your merge of that, I'll just check that everything else seems to be fine in the mean time...

Member

bagder commented Apr 9, 2018

I'll await your merge of that, I'll just check that everything else seems to be fine in the mean time...

@@ -145,7 +145,7 @@ script:
# Uncomment this when `coverage` runs on Trusty.
# set -eo pipefail
if [ "$T" = "coverage" ]; then
- export CC="gcc-6"
+ export CC="gcc-7"

This comment has been minimized.

Show comment Hide comment
@MarcelRaad

MarcelRaad Apr 10, 2018

Member

When I updated the GCC version in 828187d, I had to change the gcov version too.

@MarcelRaad

MarcelRaad Apr 10, 2018

Member

When I updated the GCC version in 828187d, I had to change the gcov version too.

This comment has been minimized.

Show comment Hide comment
@bagder

bagder Apr 10, 2018

Member

Ah yes, I suspected this as well... thanks!

@bagder

bagder Apr 10, 2018

Member

Ah yes, I suspected this as well... thanks!

@bagder bagder closed this in ac6c867 Apr 10, 2018

@bagder bagder deleted the bagder/travis-llvm-toolchain-trusty-6.0 branch Apr 11, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment