Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

runtests: make 'oldlibssh' be before 0.9.4 #8548

Closed
wants to merge 1 commit into from

Conversation

pghmcfc
Copy link
Contributor

@pghmcfc pghmcfc commented Mar 6, 2022

The 'oldlibssh' feature indicates that the error code returned by libssh for a broken known_hosts file should be 67 rather than 60 (test1459). This feature was added as part of #8444 with 'oldlibssh' mapping to libssh versions prior to 0.9.6, and then refined as part of #8511 to map to versions prior to 0.9.5.

In Red Hat Enterprise Linux 8.5 there is a patched version of libssh version 0.9.4 (https://git.centos.org/rpms/libssh/blob/c8/f/SOURCES) in which test1459 fails because it returns the "new" value rather than the "old" one. It's plausible that one of the patches is responsible for this rather than the underlying code but I don't think so.

This change therefore drops the 'oldlibssh' version check to map to libssh versions older than 0.9.4, which fixes builds on RHEL-8.

The 'oldlibssh' feature indicates that the error code returned by libssh
for a broken known_hosts file should be 67 rather than 60 (test1459).
This feature was added as part of curl#8444 with 'oldlibssh' mapping to
libssh versions prior to 0.9.6, and then refined as part of curl#8511 to map
to versions prior to 0.9.5.

In Red Hat Enterprise Linux 8.5 there is a patched version of libssh
version 0.9.4 (https://git.centos.org/rpms/libssh/blob/c8/f/SOURCES)
in which test1459 fails because it returns the "new" value rather than
the "old" one. It's plausible that one of the patches is responsible
for this rather than the underlying code but I don't think so.

This change therefore drops the 'oldlibssh' version check to map to
libssh versions older than 0.9.4, which fixes builds on RHEL-8.
bagder
bagder approved these changes Mar 7, 2022
Copy link
Member

@bagder bagder left a comment

I thought I had a libssh 0.9.4 install somewhere show up as "old" but now when I look for it I can't find it so I'll go with your move here until we find a reason to think otherwise.

@bagder
Copy link
Member

@bagder bagder commented Mar 7, 2022

Thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

2 participants