Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

wolfSSL: explicitly use compatibility layer #8864

Closed
wants to merge 1 commit into from
Closed

Conversation

elms
Copy link
Contributor

@elms elms commented May 17, 2022

This change removes adding an include $prefix/wolfssl or similar to allow for openssl include aliasing. Include paths of
wolfssl/openssl/ are used to explicitly use wolfSSL includes. This fixes cmake builds(see microsoft/vcpkg#24348) as well as avoiding potentially using openSSL headers since include path order is not guaranteed.

@elms elms force-pushed the wolfssl_ntlm branch 2 times, most recently from 7ecedf7 to 212907f Compare May 17, 2022
This change removes adding an include `$prefix/wolfssl` or similar to
allow for openssl include aliasing. Include paths of
`wolfssl/openssl/` are used to explicitly use wolfSSL includes. This
fixes cmake builds as well as avoiding potentially using openSSL
headers since include path order is not guaranteed.
bagder
bagder approved these changes May 17, 2022
Copy link
Member

@bagder bagder left a comment

Nice cleanup!

@bagder bagder closed this in 835a205 May 17, 2022
@bagder
Copy link
Member

@bagder bagder commented May 17, 2022

Thanks!

@elms elms deleted the wolfssl_ntlm branch May 17, 2022
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

2 participants