Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

amissl: make AmiSSL v5 a minimum requirement #9267

Closed
wants to merge 1 commit into from

Conversation

Futaura
Copy link
Contributor

@Futaura Futaura commented Aug 7, 2022

AmiSSL v5 is the latest version, featuring a port of OpenSSL 3.0.
Support for previous OpenSSL 1.1.x versions has been dropped, so
makes sense to enforce v5 as the minimum requirement. This also
allows all the AmiSSL stub workarounds to be removed as they are
now provided in a link library in the AmiSSL SDK.

AmiSSL v5 is the latest version, featuring a port of OpenSSL 3.0.
Support for previous OpenSSL 1.1.x versions has been dropped, so
makes sense to enforce v5 as the minimum requirement. This also
allows all the AmiSSL stub workarounds to be removed as they are
now provided in a link library in the AmiSSL SDK.
bagder
bagder approved these changes Aug 8, 2022
Copy link
Member

@bagder bagder left a comment

We have no Amiga CI and from what I can tell very few developers using it, so as long as all other platforms are still fine and the developer of this PR says it works fine on Amiga I figure we need to accept their word for it.

@bagder bagder closed this in e1acfaf Aug 8, 2022
@bagder
Copy link
Member

bagder commented Aug 8, 2022

thanks!

@Futaura Futaura deleted the amisslv5 branch Aug 8, 2022
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

2 participants