Permalink
Browse files

configure: remove libzvbi GPL dependency

The COPYING.LIB file in the zvbi source tree as well as libzvbi.h references
the GNU Library General Public License version 2 since version 0.2.28.

Signed-off-by: Marton Balint <cus@passwd.hu>
  • Loading branch information...
1 parent b77f92c commit edb4fb9016ae310d7c576bd07831b1282aae5b14 @cus committed Jan 14, 2016
Showing with 3 additions and 8 deletions.
  1. +3 −2 configure
  2. +0 −6 doc/general.texi
View
@@ -4873,7 +4873,6 @@ die_license_disabled gpl libx264
die_license_disabled gpl libx265
die_license_disabled gpl libxavs
die_license_disabled gpl libxvid
-die_license_disabled gpl libzvbi
die_license_disabled gpl x11grab
die_license_disabled nonfree libaacplus
@@ -5558,7 +5557,9 @@ enabled libxavs && require libxavs xavs.h xavs_encoder_encode -lxavs
enabled libxvid && require libxvid xvid.h xvid_global -lxvidcore
enabled libzimg && require_pkg_config zimg zimg.h zimg_get_api_version
enabled libzmq && require_pkg_config libzmq zmq.h zmq_ctx_new
-enabled libzvbi && require libzvbi libzvbi.h vbi_decoder_new -lzvbi
+enabled libzvbi && require libzvbi libzvbi.h vbi_decoder_new -lzvbi &&
+ { check_cpp_condition libzvbi.h "VBI_VERSION_MAJOR > 0 || VBI_VERSION_MINOR > 2 || VBI_VERSION_MINOR == 2 && VBI_VERSION_MICRO >= 28" ||
+ enabled gpl || die "ERROR: libzvbi requires version 0.2.28 or --enable-gpl."; }
enabled mmal && { check_lib interface/mmal/mmal.h mmal_port_connect -lmmal_core -lmmal_util -lmmal_vc_client -lbcm_host ||
{ ! enabled cross_compile && {
add_cflags -isystem/opt/vc/include/ -isystem/opt/vc/include/interface/vmcs_host/linux -isystem/opt/vc/include/interface/vcos/pthreads -fgnu89-inline ;
View
@@ -173,12 +173,6 @@ Go to @url{http://sourceforge.net/projects/zapping/} and follow the instructions
installing the library. Then pass @code{--enable-libzvbi} to configure to
enable it.
-@float NOTE
-libzvbi is licensed under the GNU General Public License Version 2 or later
-(see @url{http://www.gnu.org/licenses/old-licenses/gpl-2.0.html} for details),
-you must upgrade FFmpeg's license to GPL in order to use it.
-@end float
-
@section AviSynth
FFmpeg can read AviSynth scripts as input. To enable support, pass

0 comments on commit edb4fb9

Please sign in to comment.