Skip to content


Subversion checkout URL

You can clone with
Download ZIP
Commits on May 31, 2011
Commits on May 24, 2011
  1. Default to disallowing replace.

    Asking forgiveness is better than asking permission.
Commits on May 19, 2011
  1. Added an disallow_replace setting, which stops you from replacing gem…

    Nick Griffiths committed
    …s that already exist on the filesystem
Commits on May 12, 2011
  1. Add licence info.

Commits on Apr 27, 2011
  1. Release 0.2.15

    * Fix UI crash for gems built for none ruby platforms.
Commits on Apr 25, 2011
  1. Merge branch 'issue-16'

  2. Merged pull request #17 from Undev/upstream-look-and-feel.

    Upstream look and feel
  3. @akzhan

    When script loaded before </body>, dom:ready event is useless (DOM bu…

    akzhan committed
    …ilt before script execution anyway), so do less
  4. @akzhan
  5. @akzhan
Commits on Apr 24, 2011
  1. Short term fix for platform != ruby UI crashes.

    We need a long term fix as this just hides the immediate problem.
    Throughout we reference gems by their name and version and ignore the platfrom.
Commits on Apr 7, 2011
  1. Version bump.

  2. New more minimal look & feel.

Commits on Apr 6, 2011
  1. Display description and author.

    Gregory Mostizky committed with
Commits on Mar 22, 2011
  1. Cleanse the password from command line output.

    Andrew J. Erickson committed with
Commits on Feb 3, 2011
Commits on Feb 1, 2011
  1. @sok-klausl

    Inserted requiring of rubygems/builder before rubygems/indexer.

    sok-klausl committed
    Running geminabox under Ruby 1.9.2 / Rubygems 1.3.x gave me several errors,
    none of which I am able to correctly reproduce - sorry for that.
    The initial bug was actually builder v3.0.0 related and made me update rubygems.
    Anyways, updating to Rubygems 1.5.0 introduced another bunch of 'uninitialized constants'
    errors, which could all be solved by requiring rubygems/builder before requiring
    To reproduce try (in an irb session):
    require 'rubygems'
    require 'rubygems/indexer'
    as opposed to:
    require 'rubygems'
    require 'rubygems/builder'
    require 'rubygems/indexer'
Commits on Jan 31, 2011
  1. @wulffeld

    Add option to specify host on cmd line. Helpful if you manage several…

    wulffeld committed with
    … geminaboxes.
    Signed-off-by: Tom Lea <>
Commits on Nov 15, 2010
  1. Release the fix for sinatra 1.1.0.

    Closes #6
Commits on Nov 12, 2010
  1. Do a prerelease for testing.

  2. Fix 'Unknown media type: ".rz"' Errors.

    Sinatra 1.1.0 bails violently when mime type not given explicitly.
Commits on Sep 16, 2010
  1. @ctrochalakis
  2. @elliotcm

    Fix minor errors in the README.

    elliotcm committed with
Commits on Aug 24, 2010
  1. Clean up alphabetical list code.

  2. @cgs

    add alphabetical index

    cgs committed with
Commits on Aug 18, 2010
  1. Add support for proxy to gem command. Uses standard http_proxy env to…

    Marcus Derencius committed with
    … detect proxy
Commits on Aug 12, 2010
  1. @gcampbell

    Change layout to HTML5. Fixes Firefox display

    gcampbell committed with
    Previously, the geminabox HTML did not have a doctype, which caused
    Firefox to render in "quirks" mode, which caused the delete buttons not
    to show up on mouseover.  Added the HTML5 doctype, and made the single
    change required to make the HTML compliant HTML5.
Commits on May 19, 2010
  1. Bump gemspec 0.2.6:

    New release includes:
     * add atom feed of pushes.
     * fix regression preventing multiple versions from being displayed.
  2. @cap10morgan
  3. @mdelagrange
Commits on May 17, 2010
  1. Clean up some icky gooey parts.

    I couldn't understand the indicese bla bla code, so me and GeorgeBrock rewrote it.
Something went wrong with that request. Please try again.