Permalink
Fetching contributors…
Cannot retrieve contributors at this time
60 lines (46 sloc) 1.8 KB
0.1.6:
0.1.5: (2017-04-10)
- Fix presentation download (markup change)
0.1.4: (2016-06-06)
- Fix Python 3 regressions introduced in h264_overlay by 0.1.3
0.1.3: (2016-06-05)
- Add support of demos to h264_overlay output (Ivan Kurnosov)
0.1.2: (2016-01-06)
- Proportional scale for the speaker overlay (Ivan Kurnosov)
0.1.1: (2015-09-28)
- Fix rmtpdump issue with long presentation (> 50 minutes)
0.1.0:
- Add support of several output type
* legacy:
From the 0.0.* branch, works with ffmpeg > 0.5
* h264:
Same as legacy but use x264. Faster encoding and smaller file size.
Require a recent ffmpeg
* h264_overlay:
Display both the slides and the speake. Use x264, encoding is much
slower than h264 (~10x)
- Removed PIL dependency
- Fix some encoding issues
- Fix broken slide download due to a markup change
0.0.8:
- Fix a regression introduced by 0.0.7, ffmpeg 0.8 does not support -n
- Remove "... presentation -c" since redundant witch "infoqscraper -c ..."
0.0.7:
- Fix "presentation download URL"
- Add --overwrite/-y option to overwrite an already existing output file.
0.0.6:
- Fix several regressions due to markup changes
0.0.5:
- Create requirements-extra-python2.6.txt for python 2.6 only dependencies
- Remove html5lib dependency. The built-in parse now works fine and a bug in
BeautifulSoup 4.2.0/html5lib prevent from parsing the pages correctly
0.0.4:
- Python 2.6 compatibility
- Fix btrfs support (handle EMLINK properly)
- ffmpeg 0.8 compatibility (and later)
- Update page scraping to reflect the new page layout (previous versions no
longer work with the new website)
0.0.3:
- Fix support of Arch Linux (and all distributions linking python to python3)
rather than to python2)
- Add --version option