Merlin package for Sublime Text 3
Python JavaScript
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
merlin
.gitignore
Context.sublime-menu
Default.sublime-commands
LICENSE.md
Main.sublime-menu
Merlin.sublime-settings
README.md
gutter-icon.png
sublime-text-merlin.py

README.md

Merlin for Sublime Text 3

About

This plugin for Sublime Text 3 allows you to analyse OCaml source code, autocomplete and infer types while writing. It checks automatically for syntax or type errors.

Installation

First of all, be sure to have merlin installed. The current supported version of merlin is 2.x. The shorter way of doing this is with opam, an OCaml package manager:

opam install merlin

Next, install the ‘Merlin’ package using Package Control or clone this repository in your Packages folder:

git clone https://github.com/cynddl/sublime-text-merlin.git Merlin

License

Sublime-Text-Merlin is licensed under the MIT License. See the file LICENSE.md for more details.