New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Remove snap CI provider, add GoCD provider #2680

Open
jennifer-shehane opened this Issue Oct 30, 2018 · 2 comments

Comments

3 participants
@jennifer-shehane
Copy link
Member

jennifer-shehane commented Oct 30, 2018

Snap CI is no longer available: https://snap-ci.com/

They recommend looking at GoCD: https://www.gocd.org

Should be updated in our CI Provider file here: https://github.com/cypress-io/cypress/blob/develop/packages/server/lib/util/ci_provider.coffee#L31

Standard GoCD environment variables listed here: https://docs.gocd.org/current/faq/environment_variables.html#standard-gocd-environment-variables

@sog01

This comment has been minimized.

Copy link

sog01 commented Jan 28, 2019

Sorry, this file https://github.com/cypress-io/cypress/blob/develop/packages/server/lib/util/ci_provider.coffee#L31 is not found

I think it should be ci_provider.js instead of ci_provider.coffee.

sog01 added a commit to sog01/cypress that referenced this issue Jan 28, 2019

Remove snap CI Provider, add GoCD provider
Fix issue cypress-io#2680

Remove snap in CI_PROVIDERS const and replace it with goCD, also add GoCD environment variable(based on https://docs.gocd.org/current/faq/environment_variables.html#standard-gocd-environment-variables)
@jennifer-shehane

This comment has been minimized.

Copy link
Member Author

jennifer-shehane commented Jan 29, 2019

Yes! We have been converting our coffeescript files to js 🙌

sog01 added a commit to sog01/cypress that referenced this issue Jan 30, 2019

Remove snap CI Provider, add GoCD provider
Fix issue cypress-io#2680

Remove snap in CI_PROVIDERS const and replace it with goCD, also add GoCD environment variable(based on https://docs.gocd.org/current/faq/environment_variables.html#standard-gocd-environment-variables)

sog01 added a commit to sog01/cypress that referenced this issue Jan 30, 2019

Remove snap CI Provider, add GoCD provider
Fix issue cypress-io#2680

Remove snap in CI_PROVIDERS const and replace it with goCD, also add GoCD environment variable(based on https://docs.gocd.org/current/faq/environment_variables.html#standard-gocd-environment-variables)
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment