Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Does not support script type="module" #3696

Closed
shakyShane opened this issue Mar 12, 2019 · 6 comments

Comments

2 participants
@shakyShane
Copy link

commented Mar 12, 2019

Current behavior:

Nothing, just a blank screen

Desired behavior:

<script type="module" src="script.js></script> should work as expected

Steps to reproduce: (app code and test code)

Just have any site attempting to use <script type="module" src="script.js></script> as mentioned here https://philipwalton.com/articles/deploying-es2015-code-in-production-today/

Versions

Mac OS Mojave

@jennifer-shehane

This comment has been minimized.

Copy link
Member

commented Mar 19, 2019

Can you verify which browser you are opening Cypress in? Is it Electron? Chrome? Are you doing it via cypress open or cypress run?

I notice that support for <script type="module" was introduce in Chrome 60+, our Electron version is using Chromium 59.

@shakyShane

This comment has been minimized.

Copy link
Author

commented Mar 19, 2019

hi @jennifer-shehane - the issue was I was using chrome when building/testing (cypress open) - but then it was switching to electron in CI.

differring default versions I think is a foot 🔫

eg: if it's always electron when headless - there should be a giant warning about using chrome to avoid this :)

@jennifer-shehane

This comment has been minimized.

Copy link
Member

commented Mar 20, 2019

You can run during cypress run with another browser by using the --browser flag. However, video recording is unavailable currently when using chrome during cypress run.

@shakyShane

This comment has been minimized.

Copy link
Author

commented Mar 20, 2019

@jennifer-shehane

This comment has been minimized.

Copy link
Member

commented Apr 29, 2019

This will be fixed by #4001 which upgrades Electron and uses Chrome 61 in our upcoming release. We'll update this issue when it is released.

@cypress-bot

This comment has been minimized.

Copy link

commented May 17, 2019

Released in 3.3.0.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.