Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Cypress 3.3.0 .should('have.focus') does not work #4265

Closed
jevors opened this issue May 21, 2019 · 4 comments

Comments

3 participants
@jevors
Copy link

commented May 21, 2019

Current behavior:

In issue #97 the behaviour for have.focus is implemented. As @Bkucera described in this specific edit it should be possible to make user of .should('have.focus'). But that doesn't work with 3.3.0, usage results in:

CypressError: The chainer: 'focus' was not found. Could not build assertion.

Desired behavior:

Be able to use .should('have.focus')

Versions

Cypress: 3.3.0
Chrome: 74
Electron: 61

@Bkucera

This comment has been minimized.

Copy link
Member

commented May 21, 2019

@jevors thanks for the heads up, somehow it was not actually merged from the 3.3.0 feature branch: https://github.com/cypress-io/cypress/compare/v3.3.0

@cypress-bot

This comment has been minimized.

Copy link

commented May 21, 2019

The code for this is done in cypress-io/cypress#4274, but has yet to be released.
We'll update this issue and reference the changelog when it's released.

@verheyenkoen

This comment has been minimized.

Copy link
Contributor

commented May 22, 2019

I guess it would be useful to update the 3.3.0 changelog removing this feature.

@cypress-bot

This comment has been minimized.

Copy link

commented May 23, 2019

Released in 3.3.1.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.