Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Peer dependency warning when installing cypress 4.3.0 #6896

Closed
crfrolik opened this issue Mar 31, 2020 · 9 comments · Fixed by #16544
Closed

Peer dependency warning when installing cypress 4.3.0 #6896

crfrolik opened this issue Mar 31, 2020 · 9 comments · Fixed by #16544
Labels
process: dependencies Related to internal dependencies topic: installation Issue during installation or downloading Cypress type: breaking change Requires a new major release version

Comments

@crfrolik
Copy link

Current behavior:

warning cypress > extract-zip > mkdirp@0.5.4: Legacy versions of mkdirp are no longer supported. Please update to mkdirp 1.x. (Note that the API surface has changed to use Promises in 1.x.)

Desired behavior:

No warnings. It looks like extract-zip 2.0.0 has addressed this, so cypress should upgrade to use it.

Versions

Cypress 4.3.0

@jennifer-shehane
Copy link
Member

Duplicate of #6730

@jennifer-shehane jennifer-shehane marked this as a duplicate of #6730 Apr 1, 2020
@jennifer-shehane jennifer-shehane added the type: duplicate This issue or pull request already exists label Apr 1, 2020
@jennifer-shehane
Copy link
Member

Actually, I'm going to reopen this specifically. If we bumped extract-zip to 2.0.0, this would be a breaking change in Cypress because their update requires Node.js 10.12. Cypress currently only requires Node.js 8+. #6905

You can safely ignore deprecation warnings though. They should not effect your run.

@jennifer-shehane jennifer-shehane added process: dependencies Related to internal dependencies type: breaking change Requires a new major release version and removed type: duplicate This issue or pull request already exists labels Apr 2, 2020
@cypress-bot cypress-bot bot added the stage: ready for work The issue is reproducible and in scope label Apr 2, 2020
@jennifer-shehane jennifer-shehane changed the title Peer dependency warning when installing cypress 4.3.0 via yarn Peer dependency warning when installing cypress 4.3.0 Apr 13, 2020
@jennifer-shehane
Copy link
Member

Still can't bump this because Cypress only requires Node.js 10+

@jennifer-shehane jennifer-shehane added the topic: installation Issue during installation or downloading Cypress label Oct 29, 2020
@sainthkh
Copy link
Contributor

sainthkh commented Dec 7, 2020

Node 10 ends of life at April 30th, 2021. Maybe we can safely update extract-zip to 2.0.0 after the date.

@jennifer-shehane
Copy link
Member

Our next major release (7.0) is scheduled for Feb 16 - the one after would be scheduled for May 10, so...could probably aim for the later release.

@jennifer-shehane
Copy link
Member

Opened an issue for dropping Node.js 10 support #9545

@jimmywarting
Copy link

Time to update extract-zip now?

@cypress-bot cypress-bot bot added stage: work in progress stage: needs review The PR code is done & tested, needs review and removed stage: ready for work The issue is reproducible and in scope stage: work in progress labels May 17, 2021
@cypress-bot cypress-bot bot added stage: pending release and removed stage: needs review The PR code is done & tested, needs review labels May 17, 2021
@cypress-bot
Copy link
Contributor

cypress-bot bot commented May 17, 2021

The code for this is done in cypress-io/cypress#16544, but has yet to be released.
We'll update this issue and reference the changelog when it's released.

@cypress-bot
Copy link
Contributor

cypress-bot bot commented May 24, 2021

Released in 7.4.0.

This comment thread has been locked. If you are still experiencing this issue after upgrading to
Cypress v7.4.0, please open a new issue.

@cypress-bot cypress-bot bot locked as resolved and limited conversation to collaborators May 24, 2021
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Labels
process: dependencies Related to internal dependencies topic: installation Issue during installation or downloading Cypress type: breaking change Requires a new major release version
Projects
None yet
Development

Successfully merging a pull request may close this issue.

4 participants