Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

tweak 1027db04 for older versions of PyPy #4236

Merged
merged 1 commit into from
Jun 17, 2021
Merged

Conversation

mattip
Copy link
Contributor

@mattip mattip commented Jun 17, 2021

In commit 1027db0, the qualification for PyPy was removed from this #ifdef. That will break pypy users for v7.3.3 and earlier (pypy v7.3.4 was released 2021-04-08). This PR replaces that commit with a more nuanced version.

xref #4234

@scoder
Copy link
Contributor

scoder commented Jun 17, 2021

Ah, sorry for that. I should have checked at the time. I just remembered (apparently incorrectly) that this was an older change.

@scoder scoder merged commit 07b8fed into cython:master Jun 17, 2021
@jakirkham
Copy link
Contributor

Would it be ok to backport this patch?

@scoder
Copy link
Contributor

scoder commented Feb 4, 2022

Picked for 0.29.x in 2d287a6

@scoder scoder modified the milestones: 3.0, 0.29.28 Feb 4, 2022
@jakirkham
Copy link
Contributor

Thanks Stefan! 😄

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

3 participants