Browse files

Merge remote-tracking branch 'upstream/master'

  • Loading branch information...
2 parents 9bcb793 + c0d403f commit aa70016be3171c7882717e6ea002a0803d116195 @dagbrown committed Jun 28, 2016
View
21 audio/libcanberra/DEPENDS
@@ -1,14 +1,15 @@
+depends libtool
depends libvorbis
-optional_depends "%UDEV" "--enable-udev" "--disable-udev" "for udev support"
+optional_depends %UDEV "--enable-udev" "--disable-udev" "for udev support"
-optional_depends "alsa-utils" "--enable-alsa --disable-oss" \
- "--enable-oss --disable-alsa" \
- "Say yes for alsa support, else no for oss"
+optional_depends alsa-utils \
+ "--enable-alsa --disable-oss" \
+ "--enable-oss --disable-alsa" \
+ "for ALSA sound support"
-optional_depends "gstreamer" "--enable-gstreamer" "--disable-gstreamer" "To enable GStreamer support"
-optional_depends "gtk+-2" "--enable-gtk" "--disable-gtk" "To enable GTK+2 support"
-# coming soon
-optional_depends "gtk+-3" "--enable-gtk3" "--disable-gtk3" "To enable GTK+3 support"
-optional_depends "pulseaudio" "--enable-pulse" "--disable-pulse" "To enable PulseAudio support"
-optional_depends "links" "--enable-lynx" "--disable-lynx" "for documentation generation"
+optional_depends gtk+-3 "--enable-gtk3" "--disable-gtk3" "to enable GTK+3 support"
+optional_depends gtk+-2 "--enable-gtk" "--disable-gtk" "to enable GTK+2 support"
+optional_depends gstreamer "--enable-gstreamer" "--disable-gstreamer" "to enable GStreamer support"
+optional_depends pulseaudio "--enable-pulse" "--disable-pulse" "to enable PulseAudio support"
+optional_depends links "--enable-lynx" "--disable-lynx" "for documentation generation"
View
9 compilers/Cython/DETAILS
@@ -1,11 +1,12 @@
MODULE=Cython
- VERSION=0.23.4
+ VERSION=0.24
SOURCE=$MODULE-$VERSION.tar.gz
- SOURCE_URL=http://www.cython.org/release/
- SOURCE_VFY=sha256:fec42fecee35d6cc02887f1eef4e4952c97402ed2800bfe41bbd9ed1a0730d8e
+ SOURCE_URL[0]=http://www.cython.org/release/
+ SOURCE_URL[1]=https://pypi.python.org/packages/b1/51/bd5ef7dff3ae02a2c6047aa18d3d06df2fb8a40b00e938e7ea2f75544cac/
+ SOURCE_VFY=sha256:6de44d8c482128efc12334641347a9c3e5098d807dd3c69e867fa8f84ec2a3f1
WEB_SITE=http://www.cython.org/
ENTERED=20120724
- UPDATED=20151013
+ UPDATED=20160628
SHORT="C extensions for Python"
cat << EOF
View
4 compilers/dart-sdk/DETAILS
@@ -1,12 +1,12 @@
MODULE=dart-sdk
- VERSION=1.17.0
+ VERSION=1.17.1
SOURCE=dartsdk-linux-ia32-release.zip
SOURCE_DIRECTORY=$BUILD_DIRECTORY/$MODULE
SOURCE_URL=http://storage.googleapis.com/dart-archive/channels/stable/release/latest/sdk/
SOURCE_VFY=sha256:ec71e23fa79b89703fdc4f2a85b66d33ceaff7a5de2ec31cc6b38bf556115ad0
WEB_SITE=http://dartlang.org/
ENTERED=20141023
- UPDATED=20160612
+ UPDATED=20160625
SHORT="The dart programming language SDK"
cat <<EOF
View
4 compilers/dart-sdk/DETAILS.x86_64
@@ -1,12 +1,12 @@
MODULE=dart-sdk
- VERSION=1.17.0
+ VERSION=1.17.1
SOURCE=dartsdk-linux-x64-release.zip
SOURCE_DIRECTORY=$BUILD_DIRECTORY/$MODULE
SOURCE_URL=http://storage.googleapis.com/dart-archive/channels/stable/release/latest/sdk/
SOURCE_VFY=sha256:181145500a777d2906795b5949e95ea7b4932f3701c43959d0dcfea1ef434222
WEB_SITE=http://dartlang.org/
ENTERED=20141023
- UPDATED=20160612
+ UPDATED=20160625
SHORT="The dart programming language SDK"
cat <<EOF
View
3 compilers/llvm/CONFIGURE
@@ -1,3 +1,2 @@
-mquery USE_CLANG "Do you want to build the clang (C compiler) front-end ?" n
-
+mquery USE_CLANG "Do you want to build the clang (C compiler) front-end ?" n
mquery USE_AMDGPU "Do you want to enable the R600 radeon backend" n
View
10 compilers/llvm/DETAILS
@@ -1,18 +1,18 @@
MODULE=llvm
- VERSION=3.7.1
+ VERSION=3.8.0
SOURCE=$MODULE-$VERSION.src.tar.xz
SOURCE2=cfe-$VERSION.src.tar.xz
SOURCE3=clang-tools-extra-$VERSION.src.tar.xz
SOURCE_DIRECTORY=${BUILD_DIRECTORY}/$MODULE-${VERSION}.src
SOURCE_URL=http://llvm.org/releases/$VERSION/
SOURCE2_URL=$SOURCE_URL
SOURCE3_URL=$SOURCE_URL
- SOURCE_VFY=sha256:be7794ed0cec42d6c682ca8e3517535b54555a3defabec83554dbc74db545ad5
- SOURCE2_VFY=sha256:56e2164c7c2a1772d5ed2a3e57485ff73ff06c97dff12edbeea1acc4412b0674
- SOURCE3_VFY=sha256:4a91edaccad1ce984c7c49a4a87db186b7f7b21267b2b03bcf4bd7820715bc6b
+ SOURCE_VFY=sha256:555b028e9ee0f6445ff8f949ea10e9cd8be0d084840e21fbbe1d31d51fc06e46
+ SOURCE2_VFY=sha256:04149236de03cf05232d68eb7cb9c50f03062e339b68f4f8a03b650a11536cf9
+ SOURCE3_VFY=sha256:afbda810106a6e64444bc164b921be928af46829117c95b996f2678ce4cb1ec4
WEB_SITE=http://www.llvm.org
ENTERED=20090128
- UPDATED=20160209
+ UPDATED=20160619
SHORT="Low Level Virtual Machine"
cat << EOF
View
6 devel/jenkins/DETAILS
@@ -1,11 +1,11 @@
MODULE=jenkins
- VERSION=2.7
+ VERSION=2.8
SOURCE=$MODULE-$VERSION.war
SOURCE_URL_FULL=http://mirrors.jenkins-ci.org/war/$VERSION/jenkins.war
- SOURCE_VFY=sha256:586b3ba1d1fcfd54a719fd34178b486a963eda91d7c56c98d7cb8ad82c6c050f
+ SOURCE_VFY=sha256:2fead2f4aa0a8ba7d76b43fdb4ff5350bdd686bc21371f600861b7a85c51c605
WEB_SITE=http://jenkins-ci.org/
ENTERED=20141027
- UPDATED=20160530
+ UPDATED=20160611
SHORT="Extendable continuous integration server"
ARCHIVE=off
LDD_CHECK=off
View
8 games/freedroidRPG/DETAILS
@@ -1,12 +1,12 @@
MODULE=freedroidRPG
- VERSION=0.16
+ VERSION=0.16.1
SOURCE=$MODULE-$VERSION.tar.gz
- SOURCE_URL=ftp://ftp.osuosl.org/pub/freedroid/freedroidRPG-$VERSION/
+ SOURCE_URL=ftp://ftp.osuosl.org/pub/freedroid/freedroidRPG-${VERSION%.*}/
SOURCE_DIRECTORY=$BUILD_DIRECTORY/freedroidrpg-$VERSION
- SOURCE_VFY=sha256:c11f28b69eed3e8e40528442d9e840847502ccd4d3d95d3f8182abc2b3b18135
+ SOURCE_VFY=sha256:426df175034b12095e7498fd80c907e507667c960ee1da331d9e5566d1b09358
WEB_SITE=http://freedroid.sourceforge.net
ENTERED=20040922
- UPDATED=20151229
+ UPDATED=20160625
SHORT="A Diablo-like extension of freedroid into an RPG"
cat << EOF
View
1 graphics/feh/DEPENDS
@@ -1,5 +1,4 @@
depends curl
-depends giblib
depends libXinerama
optional_depends ImageMagick "" "" "for more graphic file formats"
View
6 graphics/feh/DETAILS
@@ -1,11 +1,11 @@
MODULE=feh
- VERSION=2.16
+ VERSION=2.16.1
SOURCE=$MODULE-$VERSION.tar.bz2
SOURCE_URL=http://feh.finalrewind.org/
- SOURCE_VFY=sha256:a2639dec600ffac3ac3d3ffb4254bef7385082b9c417bef72167b7b258778e4c
+ SOURCE_VFY=sha256:6e55289a3be4495a437a0b037c7b5e86edf64ec74ab63d2d26fa50df1b62b6b3
WEB_SITE=http://feh.finalrewind.org/
ENTERED=20011101
- UPDATED=20160612
+ UPDATED=20160625
SHORT="A fast, lightweight image viewer which uses imlib2"
cat << EOF
View
7 graphics/freetype2/BUILD
@@ -1,3 +1,10 @@
+# there's a circular depend on harfbuzz
+if module_installed harfbuzz; then
+ OPTS+=" --with-harfbuzz"
+else
+ OPTS+=" --without-harfbuzz"
+fi &&
+
OPTS+=" --disable-static" &&
default_build &&
View
6 graphics/freetype2/DEPENDS
@@ -1,4 +1,6 @@
-optional_depends zlib "--with-zlib" "--without-zlib" "for zlib compression support, no=use internal zlib instead of system"
+optional_depends zlib "--with-zlib" "--without-zlib" "for system zlib compression support"
optional_depends bzip2 "--with-bzip2" "--without-bzip2" "for support of bzip2 compressed fonts"
optional_depends libpng "--with-png" "--without-png" "for support of png compressed OpenType embeded bitmaps"
-optional_depends harfbuzz "--with-harfbuzz" "--without-harfbuzz" "for improved OpenType features auto-hinting"
+
+# circular depend on harfbuzz
+#optional_depends harfbuzz "--with-harfbuzz" "--without-harfbuzz" "for improved OpenType features auto-hinting"
View
2 graphics/freetype2/DETAILS
@@ -13,7 +13,7 @@ SOURCE_DIRECTORY=$BUILD_DIRECTORY/freetype-$VERSION
SOURCE3_VFY=sha256:88c8587bd92901bec885aba2674c163098971771fd567f050cb5e4217c83a4f3
WEB_SITE=http://www.freetype.org/
ENTERED=20010922
- UPDATED=20160209
+ UPDATED=20160624
SHORT="A free, quality, portable font engine"
cat << EOF
View
5 graphics/freetype2/POST_INSTALL
@@ -1,3 +1,8 @@
if module_installed pango; then
lin -c pango
+fi &&
+
+if module_installed harfbuzz; then
+ lin -c harfbuzz
fi
+
View
4 graphics/harfbuzz/DEPENDS
@@ -2,7 +2,7 @@ depends glib-2
depends pbzip2
optional_depends graphite \
- "--with-graphite2" \
+ "--with-graphite2" \
"--without-graphite2" \
"for additional shapers support"
@@ -25,5 +25,3 @@ optional_depends gobject-introspection \
"--with-gobject=yes --enable-introspection=yes" \
"--with-gobject=no --enable-introspection=no" \
"for gobject introspection support"
-
-
View
6 i18n/aspell-pt/DETAILS
@@ -1,13 +1,13 @@
MODULE=aspell-pt
LANG=pt_PT
- VERSION=20160406
+ VERSION=20160624
SOURCE=aspell6.pt-$VERSION.tar.bz2
SOURCE_DIRECTORY=$BUILD_DIRECTORY/aspell6-$LANG-$VERSION-0
SOURCE_URL=http://natura.di.uminho.pt/download/sources/Dictionaries/aspell6/
- SOURCE_VFY=sha256:e6eb206e66233892b8efbb15039547d3f8cc6f3c3261e166134b39c01fa56bac
+ SOURCE_VFY=sha256:a77d9b3c6cd9dd5147ae7d5d810787c994c5278d45fcae277f8d06eba8004119
WEB_SITE=http://aspell.net/
ENTERED=20011028
- UPDATED=20160418
+ UPDATED=20160625
SHORT="Portugese aspell dictionary"
cat << EOF
View
6 libs/libinput/DETAILS
@@ -1,11 +1,11 @@
MODULE=libinput
- VERSION=1.3.2
+ VERSION=1.3.3
SOURCE=$MODULE-$VERSION.tar.xz
SOURCE_URL=http://freedesktop.org/software/libinput
- SOURCE_VFY=sha256:0701230781b59c0f1510ae86da15a7b15655e723ace366ad479ccb09fe92a183
+ SOURCE_VFY=sha256:30c8edfe47654a38c235ac6b0541d79fd593d010bc18cdda8bd1f6cc6ad8b1ce
WEB_SITE=http://wiki.freedesktop.org/www/Software/libinput/
ENTERED=20151211
- UPDATED=20160616
+ UPDATED=20160625
SHORT="handles input devices for display servers and other applications"
cat << EOF
View
6 libs/nss/DETAILS
@@ -1,12 +1,12 @@
MODULE=nss
- VERSION=3.24
+ VERSION=3.25
SOURCE=$MODULE-$VERSION.tar.gz
SOURCE_URL[0]=http://ftp.mozilla.org/pub/mozilla.org/security/nss/releases/NSS_${VERSION//./_}_RTM/src
SOURCE_URL[1]=ftp://ftp.mozilla.org/pub/mozilla.org/security/nss/releases/NSS_${VERSION//./_}_RTM/src
- SOURCE_VFY=sha256:2f0841492f91cca473b73dec6cab9cf765a485e032d48d2e8ae7261e54c419ed
+ SOURCE_VFY=sha256:5d1ad475da19d0c033a716350dc5f8a747999d3eba5ac07ee0368c5bad6e2359
WEB_SITE=http://www.mozilla.org/projects/security/pki/nss/
ENTERED=20060418
- UPDATED=20160524
+ UPDATED=20160626
SHORT="A set of libraries for security-enabled applications developement"
PSAFE="no"
View
8 lxde/menu-cache/BUILD
@@ -1,3 +1,9 @@
+OPTS+=" --libexecdir=/usr/lib" &&
+
cp $SCRIPT_DIRECTORY/menu-cache-gen.h $SOURCE_DIRECTORY/menu-cache-gen/ &&
-default_build
+default_build &&
+
+# remove the static library
+rm -f /usr/lib/libmenu-cache.a
+
View
4 python/numpy/DEPENDS
@@ -1,7 +1,7 @@
-optional_depends Python-3 "" "" "For Python 3 support"
-
depends Cython
+optional_depends Python-3 "" "" "for Python 3 support"
+
# Numpy automatically detects these and has no bih red button to ignore their presense.
optional_depends lapack "" "" "for lapack fortrab subroutine support"
optional_depends atlas "" "" "for atlas support"
View
6 python/numpy/DETAILS
@@ -1,11 +1,11 @@
MODULE=numpy
- VERSION=1.11.0
+ VERSION=1.11.1
SOURCE=$MODULE-$VERSION.tar.gz
SOURCE_URL_FULL=http://github.com/numpy/numpy/archive/v$VERSION.tar.gz
- SOURCE_VFY=sha256:e898e1f2b89092b95352a0a583152a184020a492ae77a38be03379d90f575996
+ SOURCE_VFY=sha256:108205d674adf9c128b6c1697d4a211bab820b11e898b5aa3779812a643bbc07
WEB_SITE=http://www.numpy.org/
ENTERED=20020708
- UPDATED=20160403
+ UPDATED=20160628
SHORT="Fundamental package for scientific computing with Python"
cat << EOF
View
6 science/R/DETAILS
@@ -1,14 +1,14 @@
MODULE=R
- VERSION=3.3.0
+ VERSION=3.3.1
SOURCE=$MODULE-$VERSION.tar.gz
SOURCE2=R-3.0.0-rmath-shared.patch
SOURCE_URL=http://cran.r-project.org/src/base/R-3
SOURCE2_URL=$PATCH_URL
- SOURCE_VFY=sha256:9256b154b1a5993d844bee7b1955cd49c99ad72cef03cce3cd1bdca1310311e4
+ SOURCE_VFY=sha256:3dc59ae5831f5380f83c169bac2103ad052efe0ecec4ffa74bde4d85a0fda9e2
SOURCE2_VFY=sha256:22d247f2b062074363d3fa6233106291d9b344cff40e56f02c217d97c6bc023f
WEB_SITE=http://www.r-project.org
ENTERED=20021010
- UPDATED=20160512
+ UPDATED=20160625
SHORT="Language and environment for statistical computing and graphics"
cat << EOF
View
6 security/sudo/DETAILS
@@ -1,11 +1,11 @@
MODULE=sudo
- VERSION=1.8.16
+ VERSION=1.8.17p1
SOURCE=$MODULE-$VERSION.tar.gz
SOURCE_URL=http://www.sudo.ws/sudo/dist/
- SOURCE_VFY=sha256:2d83826fc5125bf073acc203dbda1cf2abeee017090ccc9dddb0431a53d5064d
+ SOURCE_VFY=sha256:c690d707fb561b3ecdf6a6de5563bc0b769388eff201c851edbace408bb155cc
WEB_SITE=http://www.sudo.ws/sudo/
ENTERED=20010922
- UPDATED=20160327
+ UPDATED=20160626
SHORT="Grant limited superuser ability to users/groups"
cat << EOF
View
6 web/chromium/DETAILS
@@ -1,17 +1,17 @@
MODULE=chromium
- VERSION=51.0.2704.84
+ VERSION=51.0.2704.106
SOURCE=$MODULE-$VERSION.tar.xz
SOURCE2=chromium-system-jinja-r8.patch
SOURCE3=chromium-widevine.patch
SOURCE_URL=http://gsdview.appspot.com/chromium-browser-official/
SOURCE2_URL=http://data.gpo.zugaina.org/pg_overlay/www-client/chromium/files/
SOURCE3_URL=http://data.gpo.zugaina.org/pg_overlay/www-client/chromium/files/
- SOURCE_VFY=sha256:33a3fe1cb8fa5be7b35aa8ae00c8b0a6dc90975bfa9aea9865180b57b0a4dc6a
+ SOURCE_VFY=sha256:
SOURCE2_VFY=sha256:5527c223a81e79f9d6550cbdf8e43c0cdc369198c495115869b96635019d6031
SOURCE3_VFY=sha256:b352ea3512368fd77b6d342a043645a61204907c3c0c564b31ac7a7aeaa6e7a5
WEB_SITE=http://www.chromium.org/Home
ENTERED=20100104
- UPDATED=20160606
+ UPDATED=20160624
SHORT="Open-source version of Google Chrome web browser"
cat << EOF
View
6 web/npm/DETAILS
@@ -1,11 +1,11 @@
MODULE=npm
- VERSION=3.9.6
+ VERSION=3.10.2
SOURCE=$MODULE-$VERSION.tar.gz
SOURCE_URL_FULL=http://github.com/npm/npm/archive/v$VERSION.tar.gz
- SOURCE_VFY=sha256:2a922720f9c2fd246fae732a0f35e87e6bfa2375f26713e4118a6e5ed0224dfa
+ SOURCE_VFY=sha256:31419fd730faac57750bf5c864747626671a35abd1966a5ea59e64e6b43feaf1
WEB_SITE=http://npmjs.org/
ENTERED=20150515
- UPDATED=20160618
+ UPDATED=20160625
SHORT="A package manager for Node.js"
cat << EOF
View
3 x11-utils/conky/DEPENDS
@@ -1,6 +1,5 @@
depends alsa-lib
depends cmake
-depends docbook-xml
depends lua
optional_depends ncurses "-D BUILD_NCURSES=ON" "" "for ncurses support"
@@ -16,7 +15,7 @@ optional_depends mpd "-D BUILD_MPD=ON" "" "for mpd support"
optional_depends cmus "-D BUILD_CMUS=ON" "" "for cmus support"
optional_depends libxnvctrl "-D BUILD_NVIDIA=ON" "" "for NVIDIA support"
-optional_depends docbook2X "-D BUILD_MAINTAINER_MODE=ON" "" "for generatind the documentation"
+optional_depends docbook2X "-D BUILD_MAINTAINER_MODE=ON" "" "for generating the documentation"
#optional_depends toluapp "" "" "for embeded Lua suport - needed for Cairo graphics"
View
6 x11-utils/conky/DETAILS
@@ -1,14 +1,14 @@
MODULE=conky
- VERSION=1.10.2
+ VERSION=1.10.3
SOURCE=$MODULE-$VERSION.tar.gz
SOURCE2=$MODULE-1.10.0-lua53.patch.gz
SOURCE_URL_FULL=http://github.com/brndnmtthws/conky/archive/v$VERSION.tar.gz
SOURCE2_URL=$PATCH_URL
- SOURCE_VFY=sha256:cc4536141d90a6403a1eccf1f36891b6dd421e69ec3803842c65113c3a109cf0
+ SOURCE_VFY=sha256:456342fca8e33f1bfce1b4020586e05b7f89953f846c42e6cf570b766bf62bd5
SOURCE2_VFY=sha256:9ebf2d538d9de6da6c32c0c1bbe85fe690691ca96e2bbcedd822eb8ba7c19dd9
WEB_SITE=http://conky.sourceforge.net
ENTERED=20060221
- UPDATED=20160504
+ UPDATED=20160626
SHORT="A light-weight system monitor"
cat << EOF
View
4 x11-utils/x11-ssh-askpass/BUILD
@@ -1,5 +1,5 @@
-./configure --libexecdir=/usr/libexec \
- --mandir=/usr/share/man &&
+./configure --libexecdir=/usr/lib \
+ --mandir=/usr/share/man &&
xmkmf &&
make includes &&

0 comments on commit aa70016

Please sign in to comment.