Installing / running unoconv on Mac Os X #125

Closed
schwarzf opened this Issue Apr 4, 2013 · 10 comments

Comments

Projects
None yet
7 participants

schwarzf commented Apr 4, 2013

I installed LibreOffice with the current installer 'LibreOffice_4.0.2_MacOS_x86.dmg' and run the latest version (GitHub master branch) of unoconv:

./unoconv
dyld: Library not loaded: /usr/local/libodep/lib/libintl.8.dylib
Referenced from: /Applications/LibreOffice.app/Contents/MacOS/LibreOfficePython.framework/Versions/3.3/Resources/Python.app/Contents/MacOS/LibreOfficePython
Reason: image not found
Trace/BPT trap: 5

The /usr/local/libodep/lib/libintl.8.dylib library does not exist at my system. Have you any suggestions what I have forgotten?

sharp commented Apr 7, 2013

ln -s /opt/local/lib/libintl.8.dylib /usr/local/libodep/lib/libintl.8.dylib

But wrong architecture with 4.x

schwarzf commented Apr 7, 2013

I already tried to use the libintl.8.dylib from my gettext installation, but it was for the wrong architecture.

ln -s /usr/local/Cellar/gettext/0.18.2/lib/libintl.8.dylib /usr/local/libodep/lib/libintl.8.dylib

/opt/local/lib/libintl.8.dylib does not exist at my system.

But thanks for your comment.

sharp commented Apr 8, 2013

Hi , I think you can try Jodconverter http://sharp.bz/posts/168-jodconverter-wen-dang-zhuan-huan

This is technically a LibreOffice bug, but it bit me, too.

Same problem here.
You see the same here: http://stackoverflow.com/questions/15860543/dyld-library-not-loaded-usr-local-libodep-lib-libintl-8-dylib
though installing macports also doesn't work for me.

Owner

dagwieers commented May 8, 2013

Please report this problem to the LibreOffice project so they can fix this for you.

Don't forget to add a reference here to the LibreOffice bugtracker so others can track it as well.

@schwarzf - did you get this working in the end?

sry - with the current LibreOffice version (4.2.1) it is working.

Great, thanks. Tested, confirmed on Mavericks.

dagwieers added the MacOS X label Apr 23, 2015

@dagwieers dagwieers added support and removed bug labels Jul 5, 2015

Owner

dagwieers commented Jul 5, 2015

With all the heads up I am going to close this issue. If you still have a related problem, feel free to reopen this issue.

dagwieers closed this Jul 5, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment