New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

0.6.x and sources that use 0.6.x cannot be compiled by JDK 1.7.0 older than 1.7.0_80 #55

Closed
dakusui opened this Issue Apr 6, 2016 · 0 comments

Comments

Projects
None yet
1 participant
@dakusui
Owner

dakusui commented Apr 6, 2016

0.6.x and sources that use 0.6.x cannot be compiled by JDK 1.7.0 older than 1.7.0_80 with following error.


annotation com.github.dakusui.jcunit.runners.standard.annotations.Checker is missing value for the attribute <clinit>

This is caused by a following bug in javac which is introduced somewhere in 1.7.0 and fixed in JDK 1.7.0_80

As of now, this is only reproduced by older 1.7.0 and not reproduced by 1.6.0_45/1.8.0_77.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment