Skip to content
Fetching contributors…
Cannot retrieve contributors at this time
51 lines (41 sloc) 1.35 KB
# make edits to this line to trigger a new travis build.
# (sometimes it errors out trying to download from PyPI)
language: python
# Use new travis-ci infrastructure
sudo: false
python:
- "2.7"
- "3.3"
- "3.4"
notifications:
email:
recipients:
- ryankdale@gmail.com
- dalerr@niddk.nih.gov
on_success: always
on_failure: always
# See http://docs.travis-ci.com/user/gui-and-headless-browsers/#Using-xvfb-to-Run-Tests-That-Require-GUI-(e.g.-a-Web-browser)
before_install:
- "export DISPLAY=:99.0"
- "sh -e /etc/init.d/xvfb start"
# Most of this is from http://conda.pydata.org/docs/travis.html
install:
- if [[ "$TRAVIS_PYTHON_VERSION" == "2.7" ]]; then
wget https://repo.continuum.io/miniconda/Miniconda-latest-Linux-x86_64.sh -O miniconda.sh;
else
wget https://repo.continuum.io/miniconda/Miniconda3-latest-Linux-x86_64.sh -O miniconda.sh;
fi
- bash miniconda.sh -b -p $HOME/miniconda
- export PATH="$HOME/miniconda/bin:$PATH"
- hash -r
- conda config --set always_yes yes --set changeps1 no
- conda update -q conda
- conda info -a
# Base env only needs to cythonize sources; test script takes care of
# everything else.
- conda install cython
script:
- ./condatest.sh "$TRAVIS_PYTHON_VERSION"
branches:
only:
- master
Something went wrong with that request. Please try again.