Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

fixed to run tests and benchmarks smothly with ruby 1.9.3 #2

Closed
wants to merge 2 commits into from

2 participants

@cocoa

Hola David, ahora tanto los tests como los benchmarks se ejecutan correctamente con ruby 1.9.3p0 (2011-10-30 revision 33570).

@damog
Owner

Sin embargo, rompería 1.8, no?

@cocoa

Totalmente cierto y entiendo que no interesa. Enviaré nuevo pull request chequeando compatibilidad con ruby-1.8.7-p352.

@cocoa cocoa closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Sep 14, 2012
Commits on Sep 16, 2012
  1. recovering compatibility with ruby-1.8.7-p352

    cocoa authored
This page is out of date. Refresh to see the latest.
View
1  Rakefile
@@ -1,4 +1,3 @@
-require 'rubygems'
require 'rake/testtask'
task :default => :test
View
3  benchmark/rfeedfinder_benchmark.rb
@@ -1,5 +1,6 @@
+require 'rubygems'
+
require "benchmark"
-require "rubygems"
sites = [
"log.damog.net",
View
5 bin/feedbag
@@ -1,7 +1,8 @@
#!/usr/bin/env ruby
-require "rubygems"
-require "feedbag"
+require 'rubygems'
+require 'feedbag'
+
def usage
%Q{
View
2  lib/feedbag.rb
@@ -21,7 +21,7 @@
# OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
# WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
-require "rubygems"
+require 'rubygems'
require "hpricot"
require "open-uri"
require "net/http"
View
5 test/test_helper.rb
@@ -1,11 +1,8 @@
require 'rubygems'
require 'test/unit'
-
-
-require 'activesupport'
+require 'active_support'
require 'active_support/test_case'
-
require 'mocha'
require File.dirname(__FILE__) + '/../lib/feedbag'
Something went wrong with that request. Please try again.