OS X Opera 11.6 - not rendering font #5

Closed
krisbulman opened this Issue Apr 2, 2012 · 14 comments

Comments

Projects
None yet
2 participants
@krisbulman

Fonts do not render in Opera 11.6 on OS X Lion.

Upd This is OS X specific. No problems under win/linux

Error console

[1 April, 2012 10:59:13 PM] Internal - /entypo/font/entypo.eot?

webfont discarded - malformed
[1 April, 2012 10:59:13 PM] Internal - /entypo/font/entypo.woff

Unable to use webfont
[1 April, 2012 10:59:13 PM] Internal - /entypo/font/entypo.ttf

Unable to use webfont
[1 April, 2012 10:59:13 PM] XML - /entypo/font/entypo.svg
Tag at line 3, column 0 to line 3, column 5
Warning: default XML namespace declaration attribute present in external DTD
subset but not specified in document.  To ensure compatibility with non-
validating XML parsers, XML namespace declarations should be declared in the
internal DTD subset or be specified in the element start tag.
  Element name: svg
  Attribute: xmlns="http://www.w3.org/2000/svg"
@puzrin

This comment has been minimized.

Show comment Hide comment
@puzrin

puzrin Apr 2, 2012

Contributor

Do you look page via http or from file system? Opera doesn't support fs.

Under linux you can use thttp to proxy local dir. Don't know about macos

Contributor

puzrin commented Apr 2, 2012

Do you look page via http or from file system? Opera doesn't support fs.

Under linux you can use thttp to proxy local dir. Don't know about macos

@puzrin

This comment has been minimized.

Show comment Hide comment
@puzrin

puzrin Apr 2, 2012

Contributor

Is it specific OS X issue ? Refreshed demo page to include woff

I've installed Opera 11.60 under Ubuntu, and it's ok.

Contributor

puzrin commented Apr 2, 2012

Is it specific OS X issue ? Refreshed demo page to include woff

I've installed Opera 11.60 under Ubuntu, and it's ok.

@krisbulman

This comment has been minimized.

Show comment Hide comment
@krisbulman

krisbulman Apr 2, 2012

Tested on a local apache setup through MAMP using wildcard DNS.

It does work in my Ubuntu instance, and it does work in Windows.

is there a gh-pages set up with the demo code?

Tested on a local apache setup through MAMP using wildcard DNS.

It does work in my Ubuntu instance, and it does work in Windows.

is there a gh-pages set up with the demo code?

@puzrin

This comment has been minimized.

Show comment Hide comment
@puzrin

puzrin Apr 2, 2012

Contributor

make gh-pages should help. See ./Makefile source for all goodies.

It just copies ./font folder to gh-pages branch.

Contributor

puzrin commented Apr 2, 2012

make gh-pages should help. See ./Makefile source for all goodies.

It just copies ./font folder to gh-pages branch.

@krisbulman

This comment has been minimized.

Show comment Hide comment
@krisbulman

krisbulman Apr 2, 2012

k, tested on github pages on a macbook pro, and macpro, both with Opera 11.6. This is a confirmed OS X specific Opera issue. I will have to check back a few revisions though, i thought i recalled this working in Opera once.

k, tested on github pages on a macbook pro, and macpro, both with Opera 11.6. This is a confirmed OS X specific Opera issue. I will have to check back a few revisions though, i thought i recalled this working in Opera once.

@puzrin

This comment has been minimized.

Show comment Hide comment
@puzrin

puzrin Apr 2, 2012

Contributor

http://fortawesome.github.com/Font-Awesome/

Does that one also have problems under opera in osx ?

Contributor

puzrin commented Apr 2, 2012

http://fortawesome.github.com/Font-Awesome/

Does that one also have problems under opera in osx ?

@krisbulman

This comment has been minimized.

Show comment Hide comment
@krisbulman

krisbulman Apr 2, 2012

No, the icons there load fine

No, the icons there load fine

@puzrin

This comment has been minimized.

Show comment Hide comment
@puzrin

puzrin Apr 2, 2012

Contributor

Hm... probably, there is something critical in font headers, that i stripped as useless.

Please, test this demo from iconic https://github.com/somerandomdude/Iconic/tree/master/font/Iconic%20Fill . It's generated in similar way, but with more headers params https://github.com/somerandomdude/Iconic/blob/master/scripts/font%20creation/blank_fill.sfd .

Contributor

puzrin commented Apr 2, 2012

Hm... probably, there is something critical in font headers, that i stripped as useless.

Please, test this demo from iconic https://github.com/somerandomdude/Iconic/tree/master/font/Iconic%20Fill . It's generated in similar way, but with more headers params https://github.com/somerandomdude/Iconic/blob/master/scripts/font%20creation/blank_fill.sfd .

@krisbulman

This comment has been minimized.

Show comment Hide comment
@krisbulman

krisbulman Apr 2, 2012

Yes, both demos work in Opera 11.06/OS X (fill and stroke)

Yes, both demos work in Opera 11.06/OS X (fill and stroke)

@puzrin

This comment has been minimized.

Show comment Hide comment
@puzrin

puzrin Apr 2, 2012

Contributor

Great! That means, that i have to roll back ripped headers, and then remove one-by-one, until we find where is a problem.

Contributor

puzrin commented Apr 2, 2012

Great! That means, that i have to roll back ripped headers, and then remove one-by-one, until we find where is a problem.

@krisbulman

This comment has been minimized.

Show comment Hide comment
@krisbulman

krisbulman Apr 2, 2012

is the sfd template file not required in this release? I don't see it in the entypo repo

is the sfd template file not required in this release? I don't see it in the entypo repo

@puzrin

This comment has been minimized.

Show comment Hide comment
@puzrin

puzrin Apr 2, 2012

Contributor

It's not needed, It just contained pre-defined values, that were moved to config in "font" section.

2549b91

I've reduced number of parameters, but seems that osx opera need some.

Contributor

puzrin commented Apr 2, 2012

It's not needed, It just contained pre-defined values, that were moved to config in "font" section.

2549b91

I've reduced number of parameters, but seems that osx opera need some.

@puzrin

This comment has been minimized.

Show comment Hide comment
@puzrin

puzrin Apr 4, 2012

Contributor

Fixed

b9097fc

Contributor

puzrin commented Apr 4, 2012

Fixed

b9097fc

@puzrin puzrin closed this Apr 4, 2012

@krisbulman

This comment has been minimized.

Show comment Hide comment
@krisbulman

krisbulman Apr 4, 2012

Cool! and here I was adding headers 1 by 1. glad this bug was spotted

Cool! and here I was adding headers 1 by 1. glad this bug was spotted

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment