Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
branch: master
Fetching contributors…

Cannot retrieve contributors at this time

17 lines (16 sloc) 2.483 kB
* Dec 28, 2011 - Releasing v3.4 - Better windows support. Fixed problem with combine_options. Fixed up readme. [hcatlin]
* Dec 21, 2011 - Refactored gem structure a little and added a few bug fixes to better support Windows users - No changes to API though [2potatocakes]
* June 2, 2011 - Releasing v3.3 - A lot more bugfixes, plus a few new features (like better mime_type accessing) [hcatlin]
* Jan 11, 2011 - Releasing v3.2 - Bugfix release. Some small changes to the API in very rare circumstances. Mostly having to do with passing multiple arguments to format options. Also, you can now query an image's "colorspace". [hcatlin]
* October 28, 2010 - Releasing v3.0. Some small bugfixes. This is 3.0 because of the big interface changes and they are fairly stable from before. [hcatlin]
* A new interface! [hcatlin]
* Adding in deprecation warnings [hcatlin]
* October 12, 2010 - Added support for loading images from URIs with the MiniMagick::Image.open method [hcatlin]
* August 28, 2010 - Just quote all arguements now. [hcatlin]
* August 24, 2010 - Closing an issue with quoting colors... Issue #11 [hcatlin]
* August 17, 2010 - Added compositing! [hcatlin]
* August 17, 2010 - Moved a lot of the command logic into the CommandBuilder. This way, we don't have to repeat things like checking to see if a MOGRIFY_COMMAND is valid or not. Also added some new tests for some behaviour I noticed that wasn't specifically being tested for. Depricated the "+" method as the API was clunky. Moved to "<<" with slightly different behaviour. Image.new(path) no longer throws an error if the 'path' isn't valid. Allows us to create new images (copies, etc), however Image.open(path) will throw an Invalid error if the file stinks. Please use valid? if you want to find out if an image is recognized. [hcatlin]
* August 17, 2010 - Merged in changes to allow subexec to run on 1.8.7.
* August 16, 2010 - Merged in a bugfix change from kepi that makes 'dashed' commands (like "auto-correct") work well with the method_missing overrides. I made some changes to that patch that included simplifying the tests and also decreasing the size of the test images again. Sorry cute cats.... but your bits aren't needed!
* July 29, 2010 - Made the test images much, much smaller. Now, the size of the gem has gone from 1,080kb to 68kb. Should save a bunch of bandwidth with bundler deploys. [hcatlin]
* July 29, 2010 - Merged in my changes to allow it to work under 1.8. subex is only used in 1.9.2.
Jump to Line
Something went wrong with that request. Please try again.