New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

As of todays update, I am running into this issue. 'common' renamed RunLoopMode.commonModes #3647

Closed
sdevo619 opened this Issue Sep 18, 2018 · 8 comments

Comments

Projects
None yet
6 participants
@sdevo619

sdevo619 commented Sep 18, 2018

What did you do?

Updated to new version of Charts on an iOS 12 project by running pod update in terminal

What did you expect to happen?

no errorrs

What happened instead?

screen shot 2018-09-17 at 7 34 57 pm

screen shot 2018-09-17 at 7 42 45 pm

Charts version/Branch/Commit Number:
Xcode version: 10
Swift version: 4.1
Platform(s) running Charts: 12
macOS version running Xcode:

Demo Project

ℹ Please link to or upload a project we can download that reproduces the issue.

@muzoman

This comment has been minimized.

muzoman commented Sep 18, 2018

Me too

@srn214

This comment has been minimized.

srn214 commented Sep 18, 2018

在pod 添加 试试

post_install do |installer|

  installer.pods_project.targets.each do |target|
      target.build_configurations.each do |config|
          if target.name == 'Charts'
              config.build_settings['SWIFT_VERSION'] = '4.2'
              else
              config.build_settings['SWIFT_VERSION'] = '4.1'
          end
      end
  end

end

@muzoman

This comment has been minimized.

muzoman commented Sep 18, 2018

在pod 添加

post_install do |installer|

  installer.pods_project.targets.each do |target|
      target.build_configurations.each do |config|
          if target.name == 'Charts'
              config.build_settings['SWIFT_VERSION'] = '4.2'
              else
              config.build_settings['SWIFT_VERSION'] = '4.1'
          end
      end
  end

end

Where is this code placed?

@srn214

This comment has been minimized.

srn214 commented Sep 18, 2018

image

@cythb

This comment has been minimized.

cythb commented Sep 19, 2018

@liuxuan30

This comment has been minimized.

Collaborator

liuxuan30 commented Sep 19, 2018

@cythb stop asking people to try 4.0 branch. IT'S NOT FOR PUBLIC. Next time I saw you post like this, I will delete it.

@liuxuan30

This comment has been minimized.

Collaborator

liuxuan30 commented Sep 19, 2018

Please note, we try to make sure master branch always work with latest Xcode and Swift; if you plan to upgrade your EVERY swift library to 4.2, you can take the new code. Otherwise, stick to old Chart library.

The new commits for Swift 4.2 will not work with lower versions.

@liuxuan30 liuxuan30 closed this Sep 19, 2018

@SURYAKANTSHARMA

This comment has been minimized.

SURYAKANTSHARMA commented Sep 24, 2018

@srn214 , @muzoman I had encounter same issue, thanks for solution 👍 , Could you please explain a bit more. Is this is setting swift version in build setting to 4.2 but why its working. Any help appreciated.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment