Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Typo is the oldest and most powerful Ruby on Rails blogware, providing custom templates, powerful drag and drop plugins API, advanced SEO capabilities, XMLRPC API and many more.
Ruby JavaScript

This branch is 3 commits ahead, 2497 commits behind publify:master

Fetching latest commit…

Cannot retrieve the latest commit at this time

Failed to load latest commit information.
.bundle
app
autotest
bin
config
db
doc
installer
lang
lib
log
public
script
spec
test
themes
vendor
.gitignore
.gitmodules
.metrics
.rspec
CHANGELOG
Gemfile
Gemfile.lock
MIT-LICENSE
README.textile
Rakefile
TODO.todo
config.ru

README.textile

About Typo

Being around since March 2005, Typo is (probably) the oldest blogging platform in Rails. It has a full set of feature you would expect from such an engine, powerful SEO capabilities and full themes and plugin
extension. It is available as a gem or source tarball.

Current version is Typo 5.5 for Ruby on Rails 2.3.8.

Useful Links:

Get some help

Maintainers
This is a list of Typo maintainers. If you have a commit bit, please add your name and contact details to the list.

The Cool Kids

Frédéric de Villamil <frederic@de-villamil.com>
blog: http://t37.net
irc: neuro`

Matijs van Zuijlen
blog: http://www.matijs.net/blog/
irc: matijs

Cyril Mougel
blog: http://blog.shingara.fr
irc: shingara

Original Author

Tobias Luetke
blog: http://blog.leetsoft.com/
irc: xal

Installing Typo

There are various way of installing Typo, but the easiest way is certainly using our gem.

1. Prerequisites

To install Typo you need the following:

  • Ruby 1.8.7 or Ruby Enterprise Edition
  • Ruby On Rails 2.3.8
  • A database engine, MySQL, PgSQL or SQLite3
  • The Ruby connector to your favourite database engine

2. Install the gem

If you have root access, just run:

  $ sudo gem install typo

Otherwise:

  $ export GEM_PATH=~/gems
  $ gem install -i ~/gems typo

3. Install Typo

Typo comes as a highly configurable binary installer. By default, it runs with Mongrel on a random port between 4000 and 5000 and SQLite3. However we recommend using a more production ready database engine and a faster, more scalable web server. MySQL and Passenger running either on Apache or Nginx are our favourite options.

To install Typo with the default options, just run:

  typo install /some/path

This will install typo with SQLite3 and will spawn it to some random port.

To chose your database engine and web server, run the following:

  typo install /some/path web-server=my_server database=my_db db_password=password db_user=my_app db_name=my_app some/path

Options for web-server are:

  • mongrel
  • mongrel_cluster
  • external: Apache, Nginx, Lighttpd… with Fastcgi, mod_rails, Thin…

For more information about installing Typo from the gem, please read our installer documentation

4. Start / stop Typo

If you’re using mongrel or mongrel_cluster you’ll be able to start / stop your Typo engine using Typo binary:

  $ typo start some/path
  $ typo stop some/path

Daily use

Typo’s administrative interface is available at http://your.domain.com/admin. You can use this to post articles and change Typo’s configuration settings. For posting new content, you can either use this administrative web interface or a desktop blog editor like MarsEdit or Ecto. For a short list of clients which are confirmed to work please visit http://typosphere.org/wiki/DesktopClients.

Enjoy,
Your typo team

Something went wrong with that request. Please try again.