Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Renaming HAVE_DEPENDENCIES to HAVE_RULES

  • Loading branch information...
commit 3bb2850c5c34f48dea5a72fcdfdeeabd6ca09433 1 parent 8057736
@danmar authored
Showing with 4 additions and 4 deletions.
  1. +1 −1  cli/cli.pro
  2. +3 −3 readme.txt
View
2  cli/cli.pro
@@ -5,7 +5,7 @@ INCLUDEPATH += . ../lib
OBJECTS_DIR = temp
CONFIG += warn_on
CONFIG -= qt app_bundle
-DEFINES += HAVE_DEPENDENCIES
+DEFINES += HAVE_RULES
BASEPATH = ../externals/tinyxml/
include($$PWD/../externals/tinyxml/tinyxml.pri)
View
6 readme.txt
@@ -18,8 +18,8 @@ Compiling
To build the GUI, you need Qt.
- To build the command line tool, PCRE is needed. More information about PCRE is found in
- build.txt
+ To build the command line tool, no dependencies are required. However for
+ the handling of rules, PCRE is needed.
There are multiple compilation choices:
* qmake - cross platform build tool
@@ -48,7 +48,7 @@ Compiling
g++ -o cppcheck -Ilib cli/*.cpp lib/*.cpp
If you want to use --rule and --rule-file then dependencies are needed:
- g++ -o cppcheck -lpcre -DHAVE_DEPENDENCIES -Ilib -Iexternals cli/*.cpp lib/*.cpp externals/tinyxml/*.cpp
+ g++ -o cppcheck -lpcre -DHAVE_RULES -Ilib -Iexternals cli/*.cpp lib/*.cpp externals/tinyxml/*.cpp
mingw
=====
make LDFLAGS=-lshlwapi
Please sign in to comment.
Something went wrong with that request. Please try again.