Permalink
Browse files

changed test directory structure

  • Loading branch information...
1 parent ed7ae92 commit 2efcc18c9448977f9de7501b0856cb019b60275b @dann committed Jan 9, 2009
View
9 Makefile.PL
@@ -47,11 +47,16 @@ requires 'MIME::Types';
# will separete these modules from core
requires 'FormValidator::Simple';
-build_requires 'Test::More';
+
+tests 't/*.t';
+test_requires 'Test::More';
+test_requires 'Test::MockObject';
+test_requires 'Test::Most';
+test_requires 'Test::Class';
install_script 'bin/angelos';
-#author_tests('xt');
+author_tests('xt');
use_test_base;
auto_include;
WriteAll;
View
2 lib/Angelos/Script/Command/Manual.pm
@@ -8,7 +8,7 @@ binmode STDOUT, ":utf8";
=head1 NAME
-Angelos::Script::Command::Manual -
+Angelos::Script::Command::Manual - Show angelos manual
=head1 DESCRIPTION
View
4 t/lib/Angelos/Test.pm
@@ -0,0 +1,4 @@
+package Angelos::Test;
+use base qw/Test::Class/;
+
+1;
View
18 t/loader.t → t/unit/loader.t
@@ -1,9 +1,19 @@
use strict;
-use Test::More tests => 1;
-use Data::Dumper;
-use lib 't/lib';
+use warnings;
+use lib 'lib', 't/lib';
+
+AngelosTest->runtests;
+
+package AngelosTest;
+use base qw/Angelos::Test/;
+use Test::More;
+
+sub dummy: Tests {
+ ok 1;
+}
+
+1;
-BEGIN { use_ok 'Angelos::Component::Loader' }
#{
# my $components
View
18 xt/98_perlcritic.t
@@ -0,0 +1,18 @@
+use strict;
+use Test::More;
+
+if ( !$ENV{TEST_CRITIC} ) {
+ plan(
+ skip_all => "Set TEST_CRITIC environment variable to run this test" );
+}
+else {
+ eval {
+ require Test::Perl::Critic;
+ require Perl::Critic;
+ die "oops. very old." if $Perl::Critic::VERSION < 1.082;
+ Test::Perl::Critic->import( -profile => 'xt/perlcriticrc' );
+ };
+ plan skip_all => "Test::Perl::Critic >= 1.082 is not installed." if $@;
+ all_critic_ok('lib');
+}
+
View
0 xt/pod.t → xt/99_pod.t
File renamed without changes.
View
0 xt/dependency.t → xt/extra/dependency.t
File renamed without changes.
View
5 xt/extra/podcoverage.t
@@ -0,0 +1,5 @@
+use Test::More;
+eval "use Test::Pod::Coverage 1.04";
+plan skip_all => "Test::Pod::Coverage 1.04 required for testing POD coverage" if $@;
+all_pod_coverage_ok();
+
View
5 xt/perlcritic.t
@@ -1,5 +0,0 @@
-use strict;
-use Test::More;
-eval { use Test::Perl::Critic -profile => 'xt/author/perlcriticrc' };
-plan skip_all => "Test::Perl::Critic is not installed." if $@;
-all_critic_ok('lib');

0 comments on commit 2efcc18

Please sign in to comment.