Skip to content
Find file
Fetching contributors…
Cannot retrieve contributors at this time
52 lines (46 sloc) 1.47 KB
import os
import sys
from setuptools import setup, find_packages
if sys.version_info[:2] < (2, 6):
raise RuntimeError('Requires Python 2.6 or better')
here = os.path.abspath(os.path.dirname(__file__))
try:
README = open(os.path.join(here, 'README.rst')).read()
CHANGES = open(os.path.join(here, 'CHANGES.rst')).read()
except IOError:
README = CHANGES = ''
install_requires=[
'setuptools',
]
tests_require = install_requires + [
'nose',
]
setup(name='classpluggable',
version='0.01',
description=('classpluggable project'),
long_description=README + '\n\n' + CHANGES,
classifiers=[
"Intended Audience :: Developers",
"Operating System :: Unix",
"Operating System :: POSIX",
"Programming Language :: Python",
"Programming Language :: Python :: 2.6",
"Programming Language :: Python :: 2.7",
"License :: OSI Approved :: BSD License",
'Topic :: Software Development :: Libraries',
'Topic :: Software Development :: Libraries :: Python Modules'
],
keywords='',
author="dann",
author_email="techmemo@gmail.com ",
url="http://github.com/dann/python-classpluggable",
license="New BSD License",
packages=find_packages(),
include_package_data=True,
zip_safe=False,
install_requires = install_requires,
tests_require = tests_require,
test_suite = 'nose.collector',
entry_points = """\
"""
)
Something went wrong with that request. Please try again.