Dygraph 1.1.1 not working on WebKit-based browser #753

Open
RadhiFadlillah opened this Issue Jun 12, 2016 · 3 comments

Projects

None yet

3 participants

@RadhiFadlillah

Dygraph v1.1.0 and v1.1.1 is not working on WebKit based browser e.g Midori, Uzbl, DWB and Surf; but v1.0.1 and prior is working.

To reproduce, open Dygraph website in WebKit based browser. I've tested it on Linux Mint 17.2 64-bit using following browser :

  • Midori 0.5.11
  • Uzbl commit 228bc38
  • DWB commit dda5aa7
  • Surf 0.7.

On all mentioned browser, graph in Dygraph home page is not working :

Graph not working

But it's working on example page :

Graph is working

@danvk
Owner
danvk commented Oct 2, 2016

Are you seeing errors in the JS console? To be honest, I've never heard of any of those browsers.

@pshevtsov
Collaborator

FYI
@danvk these browsers are based on WebKitGTK+ (https://webkitgtk.org/).
@RadhiFadlillah you could check rstudio/dygraphs repository to see if there were some similar issues (and fixes) since RStudio IDE itself uses WebKit (not GTK+ but QT) for web view.

@RadhiFadlillah

Sorry for late reply. I've created a Dygraph chart following tutorials :

<html>

<head>
    <script type="text/javascript" src="dygraph-combined-dev.js"></script>
</head>

<body>
    <div id="graphdiv2" style="width:500px; height:300px;"></div>

    <script type="text/javascript">
        g2 = new Dygraph(
            document.getElementById("graphdiv2"),
            "temperatures.csv", 
            {}
        );
    </script>
</body>

</html>

When tested in Surf browser, console shows these errors :

dygraph issue

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment