Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

should list zlib as a dependency or bump required version of Node. #60

Closed
nickradford opened this Issue · 2 comments

3 participants

@nickradford

Restler has a requirement on zlib, which is not part of the currently listed minimum version of Node required to use Restler.

@bcherry

+1

zlib was introduced in Node 0.6.0: http://blog.nodejs.org/2011/11/05/node-v0-6-0/

I tried declaring a dependency via NPM for 'zlib', but it did not result in test passage. 2/3 "Deserialization tests" were failing (although I can't say for sure this is due to zlib, it might be something else about 0.4.7)

Unfortunately, this is bubbling up to cause a fresh install of everyauth to fail in Node 0.4.7 (which is what Heroku uses). I'll file an issue there to downgrade the restler dependency.

@ayoung
Collaborator

We will likely bump the required version of node in the next major version of restler. I'm not able to verify why it doesn't work on versions of node less than 0.6.x without downgrading my node env. But this issue should be fixed in the next version for sure.

@ayoung ayoung closed this in 6595b96
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.