Skip to content
Perl module for simple prompting with hooks for validation.
Perl
Find file
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Failed to load latest commit information.
examples
lib/IO/Prompt
t
.gitignore
Changes
MANIFEST
MANIFEST.SKIP
META.json
META.yml
Makefile.PL
README

README

IO-Prompt-Hooked

Simple prompting with validation hooks.

DESCRIPTION

Simple, portable prompts, similar to IO::Prompt::Tiny, but with
simple validation hooks.

INSTALLATION

To install this module, run the following commands:

    perl Makefile.PL
    make
    make test
    make install

DEPENDENCIES

Params::Smart, IO::Prompt::Tiny.
Minimum Perl version is 5.6.2.
The test suite requires Capture::Tiny.

SUPPORT AND DOCUMENTATION

After installing, you can find documentation for this module with the
perldoc command.

    perldoc IO::Prompt::Tiny

You can also look for information at:

    Github repo:
        http://www.github.com/daoswald/IO-Prompt-Hooked

    RT, CPAN's request tracker (report bugs here)
        http://rt.cpan.org/NoAuth/Bugs.html?Dist=IO-Prompt-Hooked

    AnnoCPAN, Annotated CPAN documentation
        http://annocpan.org/dist/IO-Prompt-Hooked

    CPAN Ratings
        http://cpanratings.perl.org/d/IO-Prompt-Hooked

    Search CPAN
        http://search.cpan.org/dist/IO-Prompt-Hooked/


LICENSE AND COPYRIGHT

Copyright (C) 2012 David Oswald

This program is free software; you can redistribute it and/or modify it
under the terms of either: the GNU General Public License as published
by the Free Software Foundation; or the Artistic License.

See http://dev.perl.org/licenses/ for more information.

Something went wrong with that request. Please try again.