Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

bundler update stuff

  • Loading branch information...
commit 369079b810d7001202a0dda34bc40ef045103aed 1 parent 731db41
@darkhelmet authored
Showing with 20 additions and 14 deletions.
  1. +4 −0 Gemfile
  2. +15 −0 Gemfile.lock
  3. +1 −14 darkblog.rb
View
4 Gemfile
@@ -29,4 +29,8 @@ if 'darkhelmet' == ENV['USER']
gem 'memcached', :path => '~/dev/github/fauna/memcached'
else
gem 'memcached-northscale', '0.19.5.3', :require => 'memcached'
+end
+
+group :development do
+ gem 'ruby-debug19'
end
View
15 Gemfile.lock
@@ -11,11 +11,15 @@ GEM
activesupport (= 2.3.8)
activesupport (2.3.8)
acts_as_taggable_on_steroids (1.2)
+ archive-tar-minitar (0.5.2)
builder (2.1.2)
+ columnize (0.3.1)
crack (0.1.6)
haml (3.0.13)
hashie (0.1.8)
hpricot (0.8.2)
+ linecache19 (0.5.11)
+ ruby_core_source (>= 0.1.4)
mime-types (1.16)
newrelic_rpm (2.10.5)
nokogiri (1.4.3.1)
@@ -30,6 +34,16 @@ GEM
rainpress (1.0)
rest-client (1.6.0)
mime-types (>= 1.16)
+ ruby-debug-base19 (0.11.23)
+ columnize (>= 0.3.1)
+ linecache19 (>= 0.5.11)
+ ruby_core_source (>= 0.1.4)
+ ruby-debug19 (0.11.6)
+ columnize (>= 0.3.1)
+ linecache19 (>= 0.5.11)
+ ruby-debug-base19 (>= 0.11.19)
+ ruby_core_source (0.1.4)
+ archive-tar-minitar (>= 0.5.2)
sanitize (1.2.0)
nokogiri (~> 1.4.1)
sinatra (1.0)
@@ -67,6 +81,7 @@ DEPENDENCIES
rack-gist (= 1.0.6)
rainpress (= 1.0.0)
rest-client (= 1.6.0)
+ ruby-debug19
sanitize (= 1.2.0)
sinatra (= 1.0)
sinatra-bundles (= 0.4.0)
View
15 darkblog.rb
@@ -6,20 +6,7 @@
$: << File.expand_path(File.join('.', 'lib'))
-begin
- # Require the preresolved locked set of gems.
- require File.expand_path('../.bundle/environment', __FILE__)
-rescue LoadError
- # Fallback on doing the resolve at runtime.
- require 'rubygems'
- begin
- require 'ruby-debug'
- rescue LoadError
- end
- require 'bundler'
- Bundler.setup
-end
-
+require 'bundler/setup'
require 'sinatra'
Bundler.require
Please sign in to comment.
Something went wrong with that request. Please try again.