Skip to content
This repository has been archived by the owner. It is now read-only.
Polymer.dart <=0.17.0 wrappers for Polymer's paper-elements
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
lib
test
.bowerrc
.gitignore
.status
CHANGELOG.md
CONTRIBUTING.md
LICENSE
README.md
bower.json
codereview.settings
paper_elements_config.yaml
pubspec.yaml

README.md

Paper elements

Note: This package is for polymer.dart < 0.17

This package wraps the Polymer project's paper elements, enabling Dart developers to easily use the Polymer implementation of Google's material design UI widgets.

You can find out more about paper elements here: http://www.polymer-project.org/docs/elements/material.html

The paper_elements package bundles all the paper elements into a single pub package, so that you can add paper_elements as a dependency in your pubspec. Installing npm and bower is not required.

Status

This is an early access version of the paper elements. The elements are still changing on both the JavaScript and Dart sides.

Using elements

All elements live at the top level of the lib/ folder.

Import into HTML:

<link rel="import" href="packages/paper_elements/paper_input.html">

Import into Dart:

import 'package:paper_elements/paper_input.dart';

Examples

All examples are located in a separate repo, https://github.com/dart-lang/polymer-core-and-paper-examples.

You can’t perform that action at this time.